summaryrefslogtreecommitdiff
path: root/dev-python/httpretty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/httpretty
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/httpretty')
-rw-r--r--dev-python/httpretty/Manifest4
-rw-r--r--dev-python/httpretty/httpretty-1.0.3.ebuild49
-rw-r--r--dev-python/httpretty/httpretty-1.0.5.ebuild2
3 files changed, 2 insertions, 53 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index 631866868aed..7561839fa9f1 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1,5 +1,3 @@
-DIST httpretty-1.0.3.tar.gz 411707 BLAKE2B b2211457c937e19f8110bc28446a2b78a8042a742341c0492589def7447e819f051d301e9d254260778f349302ccf6fc163a9f2280a55af925ae353752450320 SHA512 a6349257376c12198d0bf7923245c34f6b8a0889946ba0c2551fd3379a8d9a8e4610de81c66f945656c1879ad3fb1485f2f4148634fcc4e156b9f0a59f7dd758
DIST httpretty-1.0.5.tar.gz 414946 BLAKE2B 8bbaac3d53fbf5744f7bf8ef952bd9305112934af24809a233ef0446886e09b7d2a897e69aded12d9e715580305d729609365b0be55f8d324cc48e6aa0699d75 SHA512 2e5f4834848ab1a0b84230f000afb0409b30b3cc1769d36ad61f712f56abc8d6076e7507598f791fe343ce282cf9e26939add71ef794ead2836badfc2321d6bb
-EBUILD httpretty-1.0.3.ebuild 1335 BLAKE2B 56ca8131d236d1ba5ed2f0b1b43a6b1648a61e7ed1663b9410baeccac1358757ada926f7f5152fdb71ee66948c4a4cbcd1711a2d94c942d6a9b242fdd5bb4a3a SHA512 56c77ca2799e6f25d252bc5db2ccdd8da5ab6c2d4aecdc2a2ac046af4038125d88a931247290f9971fa7bd94d7a3688860fa72c8099ca437411764a0b8f6b9d4
-EBUILD httpretty-1.0.5.ebuild 1342 BLAKE2B 0acbfaf2080816c23bf5156ee80d7235c4392de91ebb1ce26439e9881394e2589ebb79ff78d07e91c1fc2e3c90d22e6a7fe72c0290c5c2f851381d9bc35f8d4c SHA512 67a9f6c54cbcd1d2a72fa7fe9aad52e157b09f76fd7df1c0514177bdaadf60a8df3dda9904e8646956997469be0f6b79ab80abbb8f15c632afde22e048d69bb7
+EBUILD httpretty-1.0.5.ebuild 1335 BLAKE2B f8c14b37da5c0e0045a7e921b0e7b6865e691d951cabff545725c42a89098786064544b83c466cb07ecf5de05d8313b54c48f11c7872523310f685ef20a0199c SHA512 0ab4ea2ca20b103c10361d858e89238583bd547e371b6bc19bf89bc3091188be0e44ed9fcd92090b55c20de1ee1ded8b34f9015a9afdf280adf03703f8766983
MISC metadata.xml 615 BLAKE2B cbb8f3643ad93eb01b98baccd41c86da491499f068f5fbfab8d9baeef534b1d71b118c798f0d09777c251694492a55cf1e9bcd8be619c5fecaad63fd8ce52c56 SHA512 9cfef8b6e35ad7a533ef9b8efe991b0e248e6ab0444a169aa47111373d4da464d883cde23a4d6a6a2920ae5b92270ff18ae87b7f41fc2f87cde4595f9b0b2c85
diff --git a/dev-python/httpretty/httpretty-1.0.3.ebuild b/dev-python/httpretty/httpretty-1.0.3.ebuild
deleted file mode 100644
index 2d8ba525802e..000000000000
--- a/dev-python/httpretty/httpretty-1.0.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-# redis skipped as it requires a redis server running
-DEPEND="
- test? (
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
- # requires running redis server
- # it is skipped correctly but it causes unnecessary dep on redis-py
- rm tests/functional/bugfixes/test_redis.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/httpretty/httpretty-1.0.5.ebuild b/dev-python/httpretty/httpretty-1.0.5.ebuild
index 0b217df07e41..0e08b6be2fcd 100644
--- a/dev-python/httpretty/httpretty-1.0.5.ebuild
+++ b/dev-python/httpretty/httpretty-1.0.5.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"