summaryrefslogtreecommitdiff
path: root/dev-python/httpretty/httpretty-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/httpretty/httpretty-1.1.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/httpretty/httpretty-1.1.4.ebuild')
-rw-r--r--dev-python/httpretty/httpretty-1.1.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/httpretty/httpretty-1.1.4.ebuild b/dev-python/httpretty/httpretty-1.1.4.ebuild
deleted file mode 100644
index ebb43b2a8e5d..000000000000
--- a/dev-python/httpretty/httpretty-1.1.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]"
-# eventlet is used only to test compat, and it doesn't support py3.10
-# redis skipped as it requires a redis server running
-BDEPEND="
- test? (
- >=dev-python/boto3-1.17.72[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.18.1[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- # remove useless deps
- sed -i -e '/rednose/d' setup.cfg || die
- # tests requiring network access
- rm tests/functional/test_passthrough.py || die
-
- distutils-r1_python_prepare_all
-}