summaryrefslogtreecommitdiff
path: root/dev-python/httpretty/httpretty-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/httpretty/httpretty-0.8.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/httpretty/httpretty-0.8.0.ebuild')
-rw-r--r--dev-python/httpretty/httpretty-0.8.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/httpretty/httpretty-0.8.0.ebuild b/dev-python/httpretty/httpretty-0.8.0.ebuild
deleted file mode 100644
index 5ed9516eff5b..000000000000
--- a/dev-python/httpretty/httpretty-0.8.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-IUSE="test"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/coverage-3.5[${PYTHON_USEDEP}]
- >=dev-python/nose-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/sure[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/requests-1.1[${PYTHON_USEDEP}]
- >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
- dev-python/ipdb )"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- if ! use test; then
- rm -rf tests/
- fi
-}
-
-python_test() {
- # https://github.com/gabrielfalcao/HTTPretty/issues/125
- nosetests tests/unit \
- -e test_recording_calls \
- -e test_playing_calls \
- -e test_callback_setting_headers_and_status_response \
- tests/functional || die "Tests failed under ${EPYTHON}"
- rm -rf tests/ "${BUILD_DIR}"/lib/tests/ || die
-}