summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
commit6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (patch)
tree122c8899fbcce481ff7c1deb35c872f0236affa9 /dev-python/httpcore
parente7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (diff)
gentoo auto-resync : 09:09:2023 - 10:33:01
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.18.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index bdc94dab468d..994913530ed7 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
DIST httpcore-0.17.3.gh.tar.gz 91500 BLAKE2B 65e6ac917f215fb3c2f6651633db29cf58b7c936b1554102bb1c2e777a289527d44472c2b92fb7c62e7e1a812a1cf9573796051f90ea088dc37fcc2052dfe10b SHA512 41f48d32caa7d7a3456528404392a257927d047f0a1c733e2a68c0fec97c7454c7f8d7d1b6851c5722cfac292dfaa478a4033c656e66d389c81c72dee8e7a7d2
+DIST httpcore-0.18.0.gh.tar.gz 94594 BLAKE2B 9602397bc2aa5941e9bfbffb7ba3e751c4ecac29a76dede6fa45f190ac7514f2e081cc67b781a8b6152c85ca3bfb051bdbc34628b95d05eba25a307e8877faa7 SHA512 3dc8114bf02226fc4ac87408163e599f4e9f70f9e5663c9eb7dc9a65b2b72861f3b19ed2f87e29ac90a8b85c5dc32a3fffdaf88e83b15df838fcbd89737b1c57
EBUILD httpcore-0.17.3.ebuild 1168 BLAKE2B 6406a80927fef46e2fc4aa55039e426d01313059f7ccf85c9946a5db7aaa3dae418233bd954d540a6bcb45014227b45b87a0c1f040ead23a62415927e5800d8a SHA512 1097c0bea70f9872c359decdc20b9e146dd2cc4c567fe1750ff578325107ffc148c54320730dace3100c0ab320086ae1360d1a36ea21730082116edaac304eae
+EBUILD httpcore-0.18.0.ebuild 1175 BLAKE2B c71241c774bdcca2535e59ff65cd9013308b1d7e10740c23e495a7b7674f20c85872e5a4095b9857590ebc416c69757ed0a2d1d12b7a9d062bcef0582737332a SHA512 d0133073741c2118ae16e9948edfd29f3eda424dc47b7d5015303a47bc5d41ca0b9ab2aaad8fe509cd51c4e292861a70b860db3b037e8f6510cbbbf00828cfd0
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-0.18.0.ebuild b/dev-python/httpcore/httpcore-0.18.0.ebuild
new file mode 100644
index 000000000000..03a72f4ae1f8
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.18.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}