summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
commit514c44bb9cc421df9c323acbad430cbb6ee5b89a (patch)
tree22621125c9bc9177d5339f093f57cb928531f33f /dev-python/httpcore
parent59c2499e0c9720169c9d5a02168c51c807a21467 (diff)
gentoo auto-resync : 15:05:2024 - 00:01:27
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-1.0.5.ebuild26
2 files changed, 24 insertions, 4 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 13c0c96aa1fa..f1a042683616 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,3 @@
DIST httpcore-1.0.5.gh.tar.gz 97696 BLAKE2B 2e05f790e0e67c36f86ac1ee47eea716f820d68678eff63e73bce0f652448d782c66764e7f1ab3f8e891ebf2243b96ba79ca211ea769bbf5df117342e2942cbb SHA512 4b37f3874e65908598b906167d5b0840f66ffef95b65110d318d9e64df5fd23770a08ea44ea2f3cf6f9db50f20bb9fec99b40323b959675b37168414cf397bf8
-EBUILD httpcore-1.0.5.ebuild 1221 BLAKE2B 240f2f97f5fa46b78e78afee39e4d6b9f51b8b767614d330ddbfbe402cf5109a5b63da5414d3b59016359f763aee403da5bc857d6f734d4cef577da3aeb507e8 SHA512 f52d5767df19583e9af721f9563f1958c0f1cf52ec177d6c42672e32a62dcd16ce1ecb5fcf786dfbecd1991f2f627f3d2a6d617b7efc90092ee9054c33a42d0c
+EBUILD httpcore-1.0.5.ebuild 1612 BLAKE2B 95133330a8b617a590e78e389b0f69888918922faeb1fe0de1188cb5626bee0a800b1a58eeb95c5fa26b96a6a7b738e1f44b690ee7c7746b72882dc4f80bde18 SHA512 5a50f297809f78513928b4464001e768c023a5d6311e734afced2c14273d2aac2de577f58b284b67bd76dd394dfc682690fd6c88f407a68c50372a32f58332a3
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-1.0.5.ebuild b/dev-python/httpcore/httpcore-1.0.5.ebuild
index 29e200461117..e1b37849a4d5 100644
--- a/dev-python/httpcore/httpcore-1.0.5.ebuild
+++ b/dev-python/httpcore/httpcore-1.0.5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 optfeature
@@ -35,15 +35,35 @@ BDEPEND="
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
dev-python/socksio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' 3.{10..12})
)
"
distutils_enable_tests pytest
+python_test() {
+ local opts=()
+ local EPYTEST_IGNORE=()
+
+ if ! has_version "dev-python/trio[${PYTHON_USEDEP}]"; then
+ opts+=( -k "not trio" )
+ EPYTEST_IGNORE+=(
+ tests/_async/test_connection_pool.py
+ )
+ fi
+
+ if ! has_version "dev-python/pytest-trio[${PYTHON_USEDEP}]"; then
+ opts+=( -m "not trio" -o addopts= )
+ fi
+
+ epytest "${opts[@]}"
+}
+
pkg_postinst() {
optfeature "SOCKS support" dev-python/socksio
}