summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 05:36:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 05:36:35 +0000
commit4a480f0f8da23a70c88c65a5c218926670f5a870 (patch)
tree2abc6251159b381d83839759b7e497a4f1ef0569 /dev-python/httpcore
parentdbcb48dedd80e9453883ed9e0b0ed4561a534e57 (diff)
gentoo auto-resync : 15:02:2024 - 05:36:35
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-1.0.3.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 8fe4e7f64c34..651a70b610d4 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
DIST httpcore-1.0.2.gh.tar.gz 95549 BLAKE2B 92aa9a936d8c6933e1840ae50e6dfb70e61c756027a0448c2f0a5d270937342bd99cdb110aae152103c0d6c966e9288a22f7166a04dbb06dfb2a6f1bf1454d87 SHA512 6fc0c686b0b02b1e822550c18a7a90d2501f9d530598511877ee8cb09a0bdc4d56afe48cbb5fab5f8c1a12ea443055fe2a081b990fa4270f84db8197646b4979
+DIST httpcore-1.0.3.gh.tar.gz 96028 BLAKE2B de71f44e21a7aedeb61bd598ea5451efdace9582b15dbbe22f2bd91e1892f21ef3ee49408cdb08ec4142eeef688c1eed003eadf43bd2a8d16a38e6fc2fdf7409 SHA512 1f17e6232a7fe5e2500d7adc67915143eff0fd4b197e5cea0ee11ad7c6b88488ac2181571b5a2f67d4bebe933886b1f273c91c565e3b739df8aaf2d6aa219cb0
EBUILD httpcore-1.0.2.ebuild 1221 BLAKE2B e69fd8414b022c4054a1bd91311a0826970af271ce3e04380a7612122317ca28da22fd731126fbde55fa1931f67a8a378280169328dfc23e550aca044285e89a SHA512 c215c7d88dc54e7ac48e503358e33ffe0d5b83e7df4e3712e7debe1b895d3e17b1957e816b2f7f0f29190a408a4d70d9c6e61ae68aec864c5add4044e9aed157
+EBUILD httpcore-1.0.3.ebuild 1229 BLAKE2B bb9e98b602caa18bd7e3a22d1aabe802253132309e36c833dccb4b3d5085e22895d99a898928b738f3b7e72393b50484868a34bb68de4fb2371b7037445a8742 SHA512 6e714920745c9da8dd56532f94564879af7b9c5c7fdfc316ddcc486ecfec25454a87bdfba357828d43062cb8f7e0b71a921664647b510f5c1fa63dfca3d717a5
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-1.0.3.ebuild b/dev-python/httpcore/httpcore-1.0.3.ebuild
new file mode 100644
index 000000000000..24a34134c031
--- /dev/null
+++ b/dev-python/httpcore/httpcore-1.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}