summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 06:26:48 +0000
commit2e0bf408961ec1023d3db1fc5d687c233661ac26 (patch)
tree96c6e46af3c356d1fb470acdf72ada482bb293f8 /dev-python/httpcore
parent48dbe17904ac8ee6f006488d8f21734b0d253db4 (diff)
gentoo auto-resync : 17:03:2023 - 06:26:48
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.17.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index e98564fc2f21..720d6a585c27 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
DIST httpcore-0.16.3.gh.tar.gz 79132 BLAKE2B c06d55ce1390085db6c15d3e96160cfb037a935d1298304856defd1778783ad1954924a48653ce165dae9cde18abec157aa72865f57e97d91a564d1b823c863c SHA512 d889da0a3fee4f190ecc3981b8af34fa9b285d00f4ad92158a085c65f3ad8fa5a97a8c711bd51f8b9518b9d2c90ecd457dee1a3d7bbf853715473f4707cc421a
+DIST httpcore-0.17.0.gh.tar.gz 82103 BLAKE2B a12d2843cd19f98d86868802fbb5af37f7223e6cbdb64ec4a36bda93237543d940cc7e71647ffbee67de57b46900a9496f2d3019d9bf0ac4cb74f5d13232708d SHA512 4bec9830df75b35a470e745955058e86cb4cc59c0eacef8d67d76be91c9297009f9af2bf745bf553607a60ff5fd2eaee5b8a497bb8b48ba3daffa08e80188ef4
EBUILD httpcore-0.16.3.ebuild 1167 BLAKE2B dd75bce8acf054670193fa690ea907bde019f17b47b9453cdc915157cce23e2e5f2216ebf9a2c1d97bfacfadc60c8fe4e3917380d48de52f2b4498d0823aa163 SHA512 e57084ca2901ae4dcba6ad4f11bcd9ad7071e7dfab3bc4398d493a8c34a45b298f02d26f916197262a1af5ed4fa5ee58531d6295cbfb0a880c67a30bb2c4bd3e
+EBUILD httpcore-0.17.0.ebuild 1175 BLAKE2B ce5f56f450d1fbfecdc4f1c0e719887372d9aae192344feae54b0e272c27af8bf5682a1dbce2041c5744593ed8574f168c58dbb443df9fbfc4f5981aab525a31 SHA512 09cfeec359819b178c64e902d7ba1d4e9c0c592eb7cb833f0eb5660df3aa1f4cfe7544e9b09a655f7dccaa48359057428876cd17e2824cb53ee27d1dda290042
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-0.17.0.ebuild b/dev-python/httpcore/httpcore-0.17.0.ebuild
new file mode 100644
index 000000000000..f5a9e34828ce
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.17.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}