summaryrefslogtreecommitdiff
path: root/dev-python/httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /dev-python/httpbin
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest2
-rw-r--r--dev-python/httpbin/httpbin-0.10.1-r2.ebuild (renamed from dev-python/httpbin/httpbin-0.10.1-r1.ebuild)6
2 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index f3c7fc6e8b91..315a8c922399 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -1,3 +1,3 @@
DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
-EBUILD httpbin-0.10.1-r1.ebuild 861 BLAKE2B adec7c3d79f6fb85e162936867779ffebc86b252dcf10751d606503b46f156b694c54a01092a23a287dfbaba8d071c4bbc46238f358cb1e3661d7429034bcedd SHA512 5b845ad808dc20d0f1070efc409c25fc86ef465a8b55f86b875fd80bf014adcbf2918548afe56c89905a278b65a0b5ce5a828bc8aa6307a5f4d9f21bd096143c
+EBUILD httpbin-0.10.1-r2.ebuild 971 BLAKE2B 6ed086d061c422535938ff7102a0fd296a02fef8c268b270935cc2d99e53d98f5f9a32103a190e4d6afe3e16061c3b0a684a4a4e43bd94c3738524c3db626b0f SHA512 e3b46bed098b2f44b652df8a5923cbedc03c63a5f5b189638cc4967ea5321c0c24a1b2af598d85182750606885520f233479a9298e0f552e01deca88588c667d
MISC metadata.xml 445 BLAKE2B c577334830bc0d51f9df221e224c231c254b3db9129e4028d53cbd96a4481728e3b721b44f569c243deeecfb38e8dc81a7566a0b7ccd665d51b1a69a3687eb18 SHA512 fcdbd0c24e12d91df89af24befa6c9600f28083c3fe38e88ebec9856f4fb5c4c137c3b85f2271422c513bbd7c31a457f8290ebc2dd755d9117d57aa42883eec8
diff --git a/dev-python/httpbin/httpbin-0.10.1-r1.ebuild b/dev-python/httpbin/httpbin-0.10.1-r2.ebuild
index 452043b95db7..d6ccf0b5a75e 100644
--- a/dev-python/httpbin/httpbin-0.10.1-r1.ebuild
+++ b/dev-python/httpbin/httpbin-0.10.1-r2.ebuild
@@ -31,3 +31,9 @@ RDEPEND="
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin greenlet
+ sed -i -e '/greenlet/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}