summaryrefslogtreecommitdiff
path: root/dev-python/httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 11:36:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 11:36:40 +0000
commitdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (patch)
tree0eeb9e8b3fe27be09da968f4c1d3e02ad5d8167d /dev-python/httpbin
parent4a480f0f8da23a70c88c65a5c218926670f5a870 (diff)
gentoo auto-resync : 15:02:2024 - 11:36:40
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest4
-rw-r--r--dev-python/httpbin/files/httpbin-0.10.1-optional-flasgger.patch24
-rw-r--r--dev-python/httpbin/httpbin-0.10.1-r5.ebuild (renamed from dev-python/httpbin/httpbin-0.10.1-r4.ebuild)0
3 files changed, 3 insertions, 25 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index 376a9632841c..6722680f94fe 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -1,5 +1,5 @@
-AUX httpbin-0.10.1-optional-flasgger.patch 3009 BLAKE2B 4e71b09cedce87f58fae6295f91efbe89e7619a8f9a778e145c34e21b2f974b37547930b331e949f656a950aef057f497e81dc6e255ff33c2f1d0ea596e45d28 SHA512 c57143d4e31c6d74d2155cb8539807ec472ffda7060fbd0e694267c06c21f9cea1b6e62003563d0cbb9dcbd1b6a515855ba5cf358fd216a9ee495bc9964d6c4f
+AUX httpbin-0.10.1-optional-flasgger.patch 2246 BLAKE2B f96db03047b779625f5107aff167eba52f6819b99c4fcded932e1c4337e02e00be15901a3a3dacaf708933c04cdf9b687a78eedd7b03fb13aac868163ee0f632 SHA512 1e161b7ead872cccda833fa7a21e82229563dd996f9d5511550becf5e5623a61a7c85034e8ccb125d39eeaf9cbefb67616d692d08554f93b1fb0295ce5530ccc
AUX httpbin-0.10.1-werkzeug-3.patch 2753 BLAKE2B eb335f980867d0f55b4f790689b890c4c92246e870f3714fcda88ec302491ff76e6cc46929d227d0ef3b5b5682152d0ad83dd97e46a16729282de1497935c5e5 SHA512 b232558f609425f7cb674bf34fa0116c76e69d93ce52df656a4d76a7fec8e5a9d6f872abc681bbafede7aa5c7187439a695fbbf18ebc5c8271001bc7776a7fb7
DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
-EBUILD httpbin-0.10.1-r4.ebuild 1273 BLAKE2B 8e9f8928bb6a813c87e7928b6f4364a1b5103efd9458196f02c323bdbbf83f1626d563d321494c12a2ca70aab06232ebd7f5c4fa4263ca804b15264dda04dddb SHA512 6e712edf26e963d4b43db50538b3d1868a0056141c4f95cde4850127421e042b2e2c2d271ea18e1698ffde93c4930fa1918eab165bf19f1a2da36a573c9f4c35
+EBUILD httpbin-0.10.1-r5.ebuild 1273 BLAKE2B 8e9f8928bb6a813c87e7928b6f4364a1b5103efd9458196f02c323bdbbf83f1626d563d321494c12a2ca70aab06232ebd7f5c4fa4263ca804b15264dda04dddb SHA512 6e712edf26e963d4b43db50538b3d1868a0056141c4f95cde4850127421e042b2e2c2d271ea18e1698ffde93c4930fa1918eab165bf19f1a2da36a573c9f4c35
MISC metadata.xml 445 BLAKE2B c577334830bc0d51f9df221e224c231c254b3db9129e4028d53cbd96a4481728e3b721b44f569c243deeecfb38e8dc81a7566a0b7ccd665d51b1a69a3687eb18 SHA512 fcdbd0c24e12d91df89af24befa6c9600f28083c3fe38e88ebec9856f4fb5c4c137c3b85f2271422c513bbd7c31a457f8290ebc2dd755d9117d57aa42883eec8
diff --git a/dev-python/httpbin/files/httpbin-0.10.1-optional-flasgger.patch b/dev-python/httpbin/files/httpbin-0.10.1-optional-flasgger.patch
index c3d87ec4144d..d4695173dad5 100644
--- a/dev-python/httpbin/files/httpbin-0.10.1-optional-flasgger.patch
+++ b/dev-python/httpbin/files/httpbin-0.10.1-optional-flasgger.patch
@@ -54,34 +54,12 @@ index a82c1b8..77576a4 100644
+ @app.route("/")
+ def no_flasgger_index():
+ """Redirect to legacy index if flasgger is not available."""
-+ return redirect(url_for("view_landing_page"))
++ return view_landing_page()
+
+
@app.route("/legacy")
def view_landing_page():
"""Generates Landing Page in legacy layout."""
-diff --git a/tests/test_httpbin.py b/tests/test_httpbin.py
-index 6b75124..2ce63a6 100755
---- a/tests/test_httpbin.py
-+++ b/tests/test_httpbin.py
-@@ -10,6 +10,7 @@ from hashlib import md5, sha256, sha512
- from io import BytesIO
-
- import httpbin
-+from httpbin.core import Swagger
- from httpbin.helpers import parse_multi_value_header
-
-
-@@ -115,7 +116,8 @@ class HttpbinTestCase(unittest.TestCase):
-
- def test_index(self):
- response = self.app.get('/', headers={'User-Agent': 'test'})
-- self.assertEqual(response.status_code, 200)
-+ self.assertEqual(response.status_code,
-+ 200 if Swagger is not None else 302)
-
- def get_data(self, response):
- if 'get_data' in dir(response):
--
2.43.0
diff --git a/dev-python/httpbin/httpbin-0.10.1-r4.ebuild b/dev-python/httpbin/httpbin-0.10.1-r5.ebuild
index d34c543e7976..d34c543e7976 100644
--- a/dev-python/httpbin/httpbin-0.10.1-r4.ebuild
+++ b/dev-python/httpbin/httpbin-0.10.1-r5.ebuild