summaryrefslogtreecommitdiff
path: root/dev-python/httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/httpbin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest3
-rw-r--r--dev-python/httpbin/httpbin-0.4.1.ebuild35
-rw-r--r--dev-python/httpbin/metadata.xml16
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
new file mode 100644
index 000000000000..3e380f22c6b6
--- /dev/null
+++ b/dev-python/httpbin/Manifest
@@ -0,0 +1,3 @@
+DIST httpbin-0.4.1.tar.gz 88101 BLAKE2B 3df333ba92d50e065a598b2dc51ff3355eb94eb4b3a3094ba79cbe95fc11424e05f187e434ac299023dfbfd790b32db070a37e08a962ac19d803de4405603bb8 SHA512 feb519ee909c5115971f4bfd488ec0f9e987cd473464721f4e343e09b9d8fc592cf48b50ff3a2960bb67310521d865091cd766ed351ebfaa2dc8193115e9f052
+EBUILD httpbin-0.4.1.ebuild 893 BLAKE2B dffd3e52f6929a494672e9d8c894cd0c687ee75dfe90e03fe9dcb1b24d27efcf4313ac14d619bf2d0ff27a4255043de40833353f476599d5975c27cca1ae0bca SHA512 a90259ef62ed2c3e2710d60914c14d2ca8405dbff8690af144577a24631c6a563514572c64a117f8e9ed3d64af4303ac6c28f5d2aefb92b441b8ad6ceb20b208
+MISC metadata.xml 500 BLAKE2B 1270abbd84e19a72d75a2955858c49c6b33a8c92da7f86fb7853fde55968a840d941fe9f7cd1ec2718e8cbcfede6166c412aac7fc40e483043330935720dd898 SHA512 014a5e115d2cd225618e78ddf226dfe4f8772815efc3e9ecf49883701127335d9cba5e216daaba3f15de2944074c0041e5fd6eaf26772f0892da891570f841e1
diff --git a/dev-python/httpbin/httpbin-0.4.1.ebuild b/dev-python/httpbin/httpbin-0.4.1.ebuild
new file mode 100644
index 000000000000..dc292762e451
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="https://github.com/Runscope/httpbin https://pypi.org/project/httpbin/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/werkzeug[${PYTHON_USEDEP}] )"
+
+# Not included
+# Someone needs to file a bug upstream
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_httpbin.py || die
+}
diff --git a/dev-python/httpbin/metadata.xml b/dev-python/httpbin/metadata.xml
new file mode 100644
index 000000000000..abe8d7d98c04
--- /dev/null
+++ b/dev-python/httpbin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>httpbin@runscope.com</email>
+ <name>Runscope</name>
+ </maintainer>
+ <remote-id type="github">Runscope/httpbin</remote-id>
+ </upstream>
+</pkgmetadata>