summaryrefslogtreecommitdiff
path: root/dev-python/httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
commit662f71ae67cd775d7fbb79b5091676c0e07a992b (patch)
tree74c7cb80b79b8886cd7466cf262878d1e8b9d546 /dev-python/httpbin
parentb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (diff)
gentoo auto-resync : 29:05:2023 - 15:17:30
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest2
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r5.ebuild6
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index ca9a7993d8c9..bac9b767caae 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -3,5 +3,5 @@ AUX httpbin-0.7.0-optional-raven.patch 1218 BLAKE2B 010a13db882711af3cd74175b873
AUX httpbin-0.7.0-test-werkzeug.patch 1108 BLAKE2B a7118afed382eeedcfb3e8ff9a31b31fb80c01cf97f19948f9d208d77289f829d3ef24f4cbdde74cc87d2d640b61a51994292fcdf5058f94b8768fd4c37a3cc1 SHA512 3556b921a6daed3dc561d78912b41ca9a3cea1274384f849bba1d7cd7e7014798ce5c9e93491351ca5225e26762be03c73cd0d09c60c90b8a55ff6e6ce0bf81f
AUX httpbin-0.7.0-werkzeug-2.1.patch 1158 BLAKE2B 7343f4dbe9886fd54fc8187bc48ed8bd016c03057c4e5de81a46c2389b8d9fdd381f687855dc8ded1d8133a47fb8f09f4ec6c8eae739ca1c157945af97a633c5 SHA512 3d9ed7ab76dc0a33d69cf973e16be7358daa0af0a48d5ac24e0ad6ea8d73a68a796b4c8526ad764c0ed09997448f744f205b909261c32405ff166b359be1fb8b
DIST httpbin-0.7.0.tar.gz 92613 BLAKE2B 59252df1d4d0ef853ec65263b472d3ba6c597336d844f9b457f2d0a009048d4222f715a7f6fb120aca00fa641d1687e302036dc151bd2fd67ba98cf5fc47a63a SHA512 82e80058b58943637e9f8191764cea79bf7a6e40f36069f9b5d3f908585dbef20a03ef070d1f865d350920b6e874a93a48a544b05c14ff4911038ec2c20f6f63
-EBUILD httpbin-0.7.0-r5.ebuild 1514 BLAKE2B 674cba1d72226eb65ccaa7b63e9f8f031c74c2971fde873c043ee5e1a6595d87bd5de8e575cc198a00f835b57099724904bd5e4bb8e542a245ef454bc374de30 SHA512 d89c75eb9c28729117f693c8f0a303b90eae43dd311734847462e6c2cd32f02e516dd9d6bef9929d61842603fcc715b8131210820c327730bdb5a8b0e383bd62
+EBUILD httpbin-0.7.0-r5.ebuild 1615 BLAKE2B 5e50812f5ae503bdb5a4e3b94bc404e7c5cb381f1a1e168d13f7405cc95aca7282c27588f96b797f488e9f37490532121f80d9445093828d3a127fcb48d51bfd SHA512 6d89f8af93f60e76c37f9eafebf8d5155a1c77353c26cc442281a240f9be9d2bd5369aed7d10b102990fd3d8cdb34f36a40ab000ff39e7b540d709b688a85555
MISC metadata.xml 394 BLAKE2B 73c2d6f27f957cfeaddc8c69cc0d7a7bf68514f1d840a982de1eaf9a62be8cf066d7b77b4b5f69fc42806979934e26d497ddf9d66d8f18dcaa32168fd83f7a0e SHA512 70c529e2d1b716a1997773f999902547010bd9406cfde38408a5941a70400e13c949f1a8fb20a53e0f0da4da91742cc259910e97cce8917dc029f3cb84d72bdd
diff --git a/dev-python/httpbin/httpbin-0.7.0-r5.ebuild b/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
index 8025d864f504..026ca9614ba7 100644
--- a/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
+++ b/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -50,6 +50,10 @@ src_prepare() {
sed -e 's:test_redirect:_&:' \
-e 's:test_relative:_&:' \
-i test_httpbin.py || die
+ # broken
+ sed -e 's:test_digest_auth:_&:' \
+ -e 's:test_base64:_&:' \
+ -i test_httpbin.py || die
distutils-r1_src_prepare
}