summaryrefslogtreecommitdiff
path: root/dev-python/httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/httpbin
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/httpbin')
-rw-r--r--dev-python/httpbin/Manifest4
-rw-r--r--dev-python/httpbin/httpbin-0.4.1.ebuild35
-rw-r--r--dev-python/httpbin/metadata.xml16
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
new file mode 100644
index 000000000000..b8fa6c6b3fbe
--- /dev/null
+++ b/dev-python/httpbin/Manifest
@@ -0,0 +1,4 @@
+DIST httpbin-0.4.1.tar.gz 88101 SHA256 3362ae9dec439912e32287e19c673a090658a4e1891f44985c1694cf81d05258 SHA512 feb519ee909c5115971f4bfd488ec0f9e987cd473464721f4e343e09b9d8fc592cf48b50ff3a2960bb67310521d865091cd766ed351ebfaa2dc8193115e9f052 WHIRLPOOL f68c97593228d354bad1acf9ee8abd88c94c9371579144ef978595891374dded4a52749f5cc936386424dea430e0112d31f1c6ebd89e2d053c471c57e292e86f
+EBUILD httpbin-0.4.1.ebuild 895 SHA256 de3ea6a479bf1d2e3337e0a8834d51dfec8573312e7251f7c35f868a7c569d19 SHA512 c4a0c07ff31963f9946b00018852ce1cd501dbda116af5882bdb40a4cbe102ab41e12b44e9efd62f0be6783e543ccfb3b45c36210e5dc9b12da1f4f34be8d0bf WHIRLPOOL 3fa4bc5c6ec4551e3cff47dd4b56eddd772f810e16e13783913a7ddd22936188e3a6cb4d0537882ce49d6d15abcd4d375732454f7aa0e54eef140acfbbf436c6
+MISC ChangeLog 1733 SHA256 3fce17eb3f60ecc7440cf8a4d969ab36276d6a631a33c0dc06df24486e083620 SHA512 9dfeb5bca5602c765cabd44a191fdb228029cdacaacbbe098e0334a34e5d95343b60a1d88686e93cb353382d2c1739992209a3aab23290ce83d7cd004be17c64 WHIRLPOOL d5e5e89f18b8e3624ee2a7cd93fcc6e07b91567e1657ac944afa9f3aff306b72f7350c024531194b3bb89ebb02a1297e52928c0f8decdf92448466ec2df8949b
+MISC metadata.xml 500 SHA256 1231fc9e991aa63457f6ca3d3dddd499b56f6f5d8cb0fb0a16ed4aac846f70b3 SHA512 014a5e115d2cd225618e78ddf226dfe4f8772815efc3e9ecf49883701127335d9cba5e216daaba3f15de2944074c0041e5fd6eaf26772f0892da891570f841e1 WHIRLPOOL 8e88892d9aff9513b500eef91b3d829728dfe500491410529796d941d742d9055b72bbb952bb448830c473ea3c2ceb6a1fa595dd9b0125124beb189fd03dc6a1
diff --git a/dev-python/httpbin/httpbin-0.4.1.ebuild b/dev-python/httpbin/httpbin-0.4.1.ebuild
new file mode 100644
index 000000000000..a2632b2ab643
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="https://github.com/Runscope/httpbin http://pypi.python.org/pypi/httpbin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/werkzeug[${PYTHON_USEDEP}] )"
+
+# Not included
+# Someone needs to file a bug upstream
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_httpbin.py || die
+}
diff --git a/dev-python/httpbin/metadata.xml b/dev-python/httpbin/metadata.xml
new file mode 100644
index 000000000000..abe8d7d98c04
--- /dev/null
+++ b/dev-python/httpbin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">httpbin</remote-id>
+ <maintainer status="unknown">
+ <email>httpbin@runscope.com</email>
+ <name>Runscope</name>
+ </maintainer>
+ <remote-id type="github">Runscope/httpbin</remote-id>
+ </upstream>
+</pkgmetadata>