summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/httpbin-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 09:34:39 +0100
commit7e2b5bc2c2e2e045de6095d46c24ee857453adf2 (patch)
tree4387abc7e6be6debdd362738e7976e0d053163a1 /dev-python/httpbin/httpbin-0.10.0.ebuild
parent9b97cf60d2411c33c1b2170b730b345ea9995002 (diff)
gentoo auto-resync : 11:08:2023 - 09:34:39
Diffstat (limited to 'dev-python/httpbin/httpbin-0.10.0.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/httpbin/httpbin-0.10.0.ebuild b/dev-python/httpbin/httpbin-0.10.0.ebuild
new file mode 100644
index 000000000000..f5bae8c0052d
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="
+ https://github.com/postmanlabs/httpbin/
+ https://pypi.org/project/httpbin/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flasgger[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ [[ ${PV} != 0.10.0 ]] && die "Remove find_packages hack!"
+ sed -i -e '/find_packages(/d' setup.py || die
+ distutils-r1_src_prepare
+}