summaryrefslogtreecommitdiff
path: root/dev-python/httpauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-27 01:15:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-27 01:15:54 +0000
commit4b5a61a22263bba1a5119af1b9b61f80517d02fd (patch)
tree7acb10c8fed343782088865ecd16bd3efe268ad7 /dev-python/httpauth
parentb3e456d42287ef73c7ff48148d18a9ea8fb8debf (diff)
gentoo auto-resync : 27:11:2022 - 01:15:53
Diffstat (limited to 'dev-python/httpauth')
-rw-r--r--dev-python/httpauth/Manifest3
-rw-r--r--dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch40
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild12
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/httpauth/Manifest b/dev-python/httpauth/Manifest
index 65488cc5f4e4..e278f4d0711c 100644
--- a/dev-python/httpauth/Manifest
+++ b/dev-python/httpauth/Manifest
@@ -1,3 +1,4 @@
+AUX httpauth-0.3-remove-nose-dependency.patch 1239 BLAKE2B e4d40f37e88b7bc0e95d012837b3a256d75f8a67c41dbf66b6bd2d11f769f584771de3a5b83707ae32f8b4d5175d8814f57bc89450ba7f049b4afe3a91474b47 SHA512 a0cc7ce2db92e9bc89b4f5ef5be393e3c8a444729f0000aead02701e7128ed0a489f08f366f3ae327e476f10b29c4d81d1e1a743ab4c5bec032ab8c1204c9564
DIST httpauth-0.3.tar.gz 4440 BLAKE2B 41c9ba9ee50b7fcc4ed409f4b34897b5243df4065fd081cd5c0951ebe2719a34a424e59c21adbcd9be133c8fe4fa4ad9dc7bec561285b873987f982f684b3682 SHA512 aa35148322a1c5ffc22a132d3062d300118aa23181a0008018d0aacfd473758d86d50ff1236d88126858a53e2f45aeea938988b2d1a8f62f80a97d8c2cc69822
-EBUILD httpauth-0.3-r1.ebuild 471 BLAKE2B b4155fd7baaec6e39dbad3daff43803f78e72b24c1ee3e2c246964f26ce2bca191e036683e300b33e958dc0c716d71999fd4553f86de3395d164e0428f5afd97 SHA512 dd144bd32e7ad1944612e91d6beaa3b027bdcb884c0b59a8305abecddd8224786d115ed6e95d45b641976551a36d9f128ff753313b1aea4414a794b1c1984d94
+EBUILD httpauth-0.3-r1.ebuild 572 BLAKE2B 4f09b41a80d176ebcc96bb153d339ce46d672e9b48f200e9d420ee91a8710be115c607ca9800f79f6b2e6a47efcc30521dd1c5a2bc96249d3403d83a8256fb27 SHA512 3d7157523b5c7908aad90b01e8e431f096893e66339752898fecb84b0028836fa7339ff4518b656d3a25f5bc2ce3a83b3bb23906cee251b7717ee08a84fddedf
MISC metadata.xml 441 BLAKE2B 2c3d0480d416c2d12e0e5a4d511a5a2c04d2e26d1ddf4a52528371f16c36059276ac7f4b2c9b0d2d40a7d93aa5d3323e1763ada535ccc37a2c5b74ee28449dc5 SHA512 17202ae2f283611ae3a31f9519c7d11b32c904e729efbf878c928d5920481d1c4279127763a4d11f89b5354c677a213909cd4db39bbef56539bf4474ad61af1c
diff --git a/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
new file mode 100644
index 000000000000..5cb607c2bb4c
--- /dev/null
+++ b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
@@ -0,0 +1,40 @@
+commit d57060ebaeca8cd38e03cc64f9ee0996e83b50a9
+Author: Jonas Haag <jonas@lophus.org>
+Date: Thu Apr 21 08:58:36 2022 +0200
+
+ Move CI to GHA (#3)
+
+--- a/tests.py
++++ b/tests.py
+@@ -10,7 +10,7 @@ except ImportError: # Python 2
+
+ from httpauth import DictHttpAuthMiddleware, DigestFileHttpAuthMiddleware, md5_str
+
+-from nose.tools import raises
++import pytest
+
+
+ def parse_dict_header(value):
+@@ -121,16 +121,16 @@ def test_without_realm():
+ assert 'Digest realm=""' in response.headers['WWW-Authenticate']
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_1():
+- DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
++ wsgi_app=wsgi_app)
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_2():
+- DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
++ wsgi_app=wsgi_app)
+
+
+ def test_ticket_1():
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
index 703fdd988ecb..ae8ef46058ed 100644
--- a/dev-python/httpauth/httpauth-0.3-r1.ebuild
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
@@ -16,4 +16,12 @@ LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_tests nose
+PATCHES=(
+ "${FILESDIR}/${P}-remove-nose-dependency.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}