summaryrefslogtreecommitdiff
path: root/dev-python/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
commitbd8ca999980e9c0c9ae40a11789c858bb58769e3 (patch)
tree355d68a84921e04a81231e74fc062f229f76a733 /dev-python/http-parser
parentb3f2504c1d05b5999b74b2135860fc721e3adf68 (diff)
gentoo auto-resync : 15:07:2022 - 13:42:19
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/Manifest1
-rw-r--r--dev-python/http-parser/http-parser-0.9.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
index 268996a2adc7..687dcac1a372 100644
--- a/dev-python/http-parser/Manifest
+++ b/dev-python/http-parser/Manifest
@@ -1,4 +1,3 @@
DIST http-parser-0.9.0.gh.tar.gz 101174 BLAKE2B 92b74dffd2c35672bc383ccda59f93723c0f83ecb0fbf0470f5daacdd37f68d4d63de7d4ea53f86d2109349a793b7535cc864f014311dee6ac5e67d0ca751931 SHA512 75e51bef43d9d7698aad69f8bfe651e24784b97603cac55f33bf4c12c86792c8c71d6206f31847d052e4d8621a5ea65a7b34eca5bebdb8189f58e6d98d33139d
EBUILD http-parser-0.9.0-r1.ebuild 884 BLAKE2B 78c66d15b5a6124842150951352ec114fb0e4bb5ed35d0c2520e6ba28b07b00c93541fff10f261a4615facb837de444c600c73499d3a76ecf40fac2f33c5ae1b SHA512 2a5bc6714a7d96dae342f98b1aacad5d04e687904bedccdfb76be02ec45d79b9f0e86c7cdabcd2b2a1ab6465a39bf3d3db13fe4a5b6743f693f66d272aefad10
-EBUILD http-parser-0.9.0.ebuild 882 BLAKE2B 0d22312cda71a086751e2ef98caaf0139296a01c07ae01be1d09f0d65a23e4ae46ff91263976e428bb0e15fd98b6b00e4f2e1499d47c9a4eb54592a97e019877 SHA512 5607df8cbf9ade92104565db3dfa14b8f4f59f7f64b0560d9c02432f33d0c6d0236f6823963801aa7ef8258b50cff816e809b20544145aa629e6ecb983a03466
MISC metadata.xml 386 BLAKE2B 219fa172d766a86094b7a37a8f5d47f6f503d14fe96ec42a7deb64e2a9865754eafcebe3514595718c54f7ad3224bd4ab227c0ff3eea9190052bf6b75712ed9a SHA512 1d6b4e4529ab169d2773199a10d994f92a638fd962bada0791c95c009ccb706a95089f9ea943e4851daa56a690319bf10cce3c77618fa1461c7c4606db2818f0
diff --git a/dev-python/http-parser/http-parser-0.9.0.ebuild b/dev-python/http-parser/http-parser-0.9.0.ebuild
deleted file mode 100644
index dc270dee7e5c..000000000000
--- a/dev-python/http-parser/http-parser-0.9.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP request/response parser for python in C"
-HOMEPAGE="https://github.com/benoitc/http-parser"
-SRC_URI="
- https://github.com/benoitc/http-parser/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~s390 ~sparc x86"
-IUSE="examples"
-
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_compile() {
- if [[ ${EPYTHON} != python3* ]]; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
-
- distutils-r1_python_compile
-}
-
-python_install_all() {
- local DOCS=( README.rst )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}