summaryrefslogtreecommitdiff
path: root/dev-python/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/http-parser
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/Manifest1
-rw-r--r--dev-python/http-parser/http-parser-0.9.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
index dadebec3273a..23f51445fe15 100644
--- a/dev-python/http-parser/Manifest
+++ b/dev-python/http-parser/Manifest
@@ -1,3 +1,4 @@
DIST http-parser-0.9.0.gh.tar.gz 101174 BLAKE2B 92b74dffd2c35672bc383ccda59f93723c0f83ecb0fbf0470f5daacdd37f68d4d63de7d4ea53f86d2109349a793b7535cc864f014311dee6ac5e67d0ca751931 SHA512 75e51bef43d9d7698aad69f8bfe651e24784b97603cac55f33bf4c12c86792c8c71d6206f31847d052e4d8621a5ea65a7b34eca5bebdb8189f58e6d98d33139d
+EBUILD http-parser-0.9.0-r1.ebuild 890 BLAKE2B 33adef9ec732bfa93b663cfc54103951546d4e1c4a829e0cdf31f5a5ca53c4bb64d0852fb4a3235a4ca006b8cb4c32a7047fb5d236db4ba7e96fe317f3bf2c31 SHA512 702a7e0a7e7adf526cd7cedd63209ace6a8e30fce05ae36567db3ec9c9ac987e7167c7bdab804f82302209af62eaa7ec49a979eb823420afac4f6d591f7a5ca1
EBUILD http-parser-0.9.0.ebuild 882 BLAKE2B 0d22312cda71a086751e2ef98caaf0139296a01c07ae01be1d09f0d65a23e4ae46ff91263976e428bb0e15fd98b6b00e4f2e1499d47c9a4eb54592a97e019877 SHA512 5607df8cbf9ade92104565db3dfa14b8f4f59f7f64b0560d9c02432f33d0c6d0236f6823963801aa7ef8258b50cff816e809b20544145aa629e6ecb983a03466
MISC metadata.xml 386 BLAKE2B 219fa172d766a86094b7a37a8f5d47f6f503d14fe96ec42a7deb64e2a9865754eafcebe3514595718c54f7ad3224bd4ab227c0ff3eea9190052bf6b75712ed9a SHA512 1d6b4e4529ab169d2773199a10d994f92a638fd962bada0791c95c009ccb706a95089f9ea943e4851daa56a690319bf10cce3c77618fa1461c7c4606db2818f0
diff --git a/dev-python/http-parser/http-parser-0.9.0-r1.ebuild b/dev-python/http-parser/http-parser-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..c974834b7586
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.9.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="
+ https://github.com/benoitc/http-parser/
+ https://pypi.org/project/http-parser/
+"
+SRC_URI="
+ https://github.com/benoitc/http-parser/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ cython -3 http_parser/parser.pyx || die
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}