summaryrefslogtreecommitdiff
path: root/dev-python/html5lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/html5lib
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest2
-rw-r--r--dev-python/html5lib/html5lib-1.0.1-r2.ebuild9
2 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
index da4589a3fa2a..823bd5338b1b 100644
--- a/dev-python/html5lib/Manifest
+++ b/dev-python/html5lib/Manifest
@@ -1,5 +1,5 @@
AUX html5lib-1.0.1-collections-abc.patch 1336 BLAKE2B 2b626d56830ff818168ca5b0fa272290e787a700c12b5295e085c0092dbe0746df1336f550573f1960bc0cb911d0639cbeb06a011a9bbeb3b2e42fcbe99e6bef SHA512 ad959536b627984948b984b700758a1e61d7f2e145a920d4020d23e7ff15fe88b31a3569c441df39122ffbedf2a1dfebf17fb00c3194c6ceb69a00f412622ecf
AUX html5lib-python-1.0.1-support-pytest4.patch 13579 BLAKE2B 723c8a77f2008978378c54a889cdd3cc28f33993d16654dff6ad7dbff69a42dcdef7c3cbd57677c88bec9650fdccdd754b488c956146168290661090a4702c9e SHA512 51435c4094fa0e0c423e21c15709e5ebe10546cbea3ac97635c3d1ebef9287d6c42a479075cc790ccf233c67924a518638d6618f073df2b0871da3fb2838e10e
DIST html5lib-1.0.1.tar.gz 252959 BLAKE2B d2a9fa19d6a18b9e0c39f737a22ff4d5a6533734843f787c083f9497fd94788dad0e1e96478fe48b262c208370cf58e91ab94cc06a3e2757a40e936363cd3148 SHA512 35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2
-EBUILD html5lib-1.0.1-r2.ebuild 1043 BLAKE2B f99581e8ddcb988421da4bc31e5c933d7e4f8f3c471dcb67cbf6b7cf51952b290e60d2f266f204eb507528e41718c976f79530c4f1387a3722c3c63fb0a3402c SHA512 0fb20fad6d89a844f460d7c580b1200e163c3abb586cb773e37d4298c7f51b99ffb222460d595c1a5b2a7dcb42729945699a6c846533fab93902f0a54600c793
+EBUILD html5lib-1.0.1-r2.ebuild 1006 BLAKE2B 7eeaa358a6864e61b9e9f99749d9ce0672fbce54142c36b24e8168fab3eb930f83ef9e763a225a0cf5a3707b5547d7b873c7ae4f21a9ddc4ab9f74f73e4c62fd SHA512 abe0b8cd95828e7e7e7308da3dfc512e4f25a01b19f4b48116f2c261b18a837411d8f9f9011b52f5ac55609c17e8a03704c0d7ef0dbaa1ac8fbec5a311cc2de4
MISC metadata.xml 614 BLAKE2B 09fb1e4c136770b5e53aecf3af9681c9155bad58e2720e6e1af9aa8d5b44c184a48bbe0d204f8af0d3e61ddf9d3b60f19ae0034d6e66b4f8683fdf7e8ecd919f SHA512 1cd9bdc5fbbedc67023c31d24901c873a9d644b8dc4f26bb5b19eda8f0fe25c413b9bf0e2b52f7e73517d744d5757881cd26bd939c39eea748dd2f84c25d983b
diff --git a/dev-python/html5lib/html5lib-1.0.1-r2.ebuild b/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
index 89f23560821f..b2553ca1f8c2 100644
--- a/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
+++ b/dev-python/html5lib/html5lib-1.0.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -16,18 +16,17 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-macos"
IUSE="test"
+RESTRICT+=" !test? ( test )"
RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
dev-python/webencodings[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
+ ${RDEPEND}
dev-python/pytest-expect[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"
-RESTRICT+=" !test? ( test )"
-
PATCHES=(
# fix deprecated import
"${FILESDIR}/html5lib-1.0.1-collections-abc.patch"