summaryrefslogtreecommitdiff
path: root/dev-python/html5lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/html5lib
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest2
-rw-r--r--dev-python/html5lib/html5lib-1.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
index 823bd5338b1b..557054fec7ec 100644
--- a/dev-python/html5lib/Manifest
+++ b/dev-python/html5lib/Manifest
@@ -1,5 +1,7 @@
AUX html5lib-1.0.1-collections-abc.patch 1336 BLAKE2B 2b626d56830ff818168ca5b0fa272290e787a700c12b5295e085c0092dbe0746df1336f550573f1960bc0cb911d0639cbeb06a011a9bbeb3b2e42fcbe99e6bef SHA512 ad959536b627984948b984b700758a1e61d7f2e145a920d4020d23e7ff15fe88b31a3569c441df39122ffbedf2a1dfebf17fb00c3194c6ceb69a00f412622ecf
AUX html5lib-python-1.0.1-support-pytest4.patch 13579 BLAKE2B 723c8a77f2008978378c54a889cdd3cc28f33993d16654dff6ad7dbff69a42dcdef7c3cbd57677c88bec9650fdccdd754b488c956146168290661090a4702c9e SHA512 51435c4094fa0e0c423e21c15709e5ebe10546cbea3ac97635c3d1ebef9287d6c42a479075cc790ccf233c67924a518638d6618f073df2b0871da3fb2838e10e
DIST html5lib-1.0.1.tar.gz 252959 BLAKE2B d2a9fa19d6a18b9e0c39f737a22ff4d5a6533734843f787c083f9497fd94788dad0e1e96478fe48b262c208370cf58e91ab94cc06a3e2757a40e936363cd3148 SHA512 35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2
+DIST html5lib-1.1.tar.gz 272215 BLAKE2B 11a4fc3fb84bf8bab4af5da1de30b0892a9eb454505716b3db391187053c9aac159b1c82ae787896592b8fc850363bba9313b9d7fc617150771c3bfa1aeadefb SHA512 af7c29591007fded99be6c38e3d0ae5a4ac32d71d26046a615918ae732cb1c1ecbf754f47ceca1a53726c3843f3ecea7af87a7362281b45ff3af495815818626
EBUILD html5lib-1.0.1-r2.ebuild 1006 BLAKE2B 7eeaa358a6864e61b9e9f99749d9ce0672fbce54142c36b24e8168fab3eb930f83ef9e763a225a0cf5a3707b5547d7b873c7ae4f21a9ddc4ab9f74f73e4c62fd SHA512 abe0b8cd95828e7e7e7308da3dfc512e4f25a01b19f4b48116f2c261b18a837411d8f9f9011b52f5ac55609c17e8a03704c0d7ef0dbaa1ac8fbec5a311cc2de4
+EBUILD html5lib-1.1.ebuild 810 BLAKE2B eb172bdbf08f5b9fa1e47cf62d8f8c95bb97280fcb300ed018582d8874e344bce06ad3b088be1a9407cd61c2a907e4adb42cdcfba6bd1ae38b9d72564ebcf786 SHA512 b952e9042a8ae86fa3c36423b373a7a4f8c95770f7e884f0df1878178b8676d05a1860ac515dbb2040d6469112093d440d70d38814f5a3f025fa9986e7a45284
MISC metadata.xml 614 BLAKE2B 09fb1e4c136770b5e53aecf3af9681c9155bad58e2720e6e1af9aa8d5b44c184a48bbe0d204f8af0d3e61ddf9d3b60f19ae0034d6e66b4f8683fdf7e8ecd919f SHA512 1cd9bdc5fbbedc67023c31d24901c873a9d644b8dc4f26bb5b19eda8f0fe25c413b9bf0e2b52f7e73517d744d5757881cd26bd939c39eea748dd2f84c25d983b
diff --git a/dev-python/html5lib/html5lib-1.1.ebuild b/dev-python/html5lib/html5lib-1.1.ebuild
new file mode 100644
index 000000000000..16f72f8d42f7
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest