summaryrefslogtreecommitdiff
path: root/dev-python/html5lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/html5lib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest7
-rw-r--r--dev-python/html5lib/html5lib-0.9999999.ebuild33
-rw-r--r--dev-python/html5lib/html5lib-0.999999999.ebuild32
-rw-r--r--dev-python/html5lib/html5lib-1.0.1.ebuild32
-rw-r--r--dev-python/html5lib/metadata.xml17
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
new file mode 100644
index 000000000000..3d7af42c6965
--- /dev/null
+++ b/dev-python/html5lib/Manifest
@@ -0,0 +1,7 @@
+DIST html5lib-0.9999999.tar.gz 889312 BLAKE2B 49cbab503692a1044ef37b11d9b776fb0378c19f1cbe05b259b4653d248e3571e5578d7879ab3ec5df2e750db74c353acc98d1d6e8556949c1b1efb62f38c116 SHA512 1748a1921f4bc93b7f208d89701eeabfe507e40515dd2e88ece239ba7c1704c8ae9dc4eea310164c7b207225dce910f78a8b34f826f4f87a2992365c07089c28
+DIST html5lib-0.999999999.tar.gz 245488 BLAKE2B 3d2409f18e7ff6b6882e163b782703a7d2b2d42f8c131ab05a51499a4cd23d75ff8d097c1ce87e9f28e8ce649bec8099d364f4d01ee64d0efdfc75fba1d01067 SHA512 b30d9ea74d0ad03e07ebee0d33caefeed717e6084f2ef44559ebf73948563ffd60e40c774e23c8964a32b0f265d1d1f0b98759861acaa208f28e5ab2813c3ca0
+DIST html5lib-1.0.1.tar.gz 252959 BLAKE2B d2a9fa19d6a18b9e0c39f737a22ff4d5a6533734843f787c083f9497fd94788dad0e1e96478fe48b262c208370cf58e91ab94cc06a3e2757a40e936363cd3148 SHA512 35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2
+EBUILD html5lib-0.9999999.ebuild 1095 BLAKE2B ad1f21c5f04ed8c270fe1fc721a608e76f286029ee088fa5f30b037a06b9bd4f96487d5e1101a4df7e0871725113d4d6c129c9554b56e39efd4923c1bb2be4be SHA512 a556b56261fda05dce6005e0e8fc9fb58fcc3de79ceef34db2ef4209ca1b8294b7dd4aeb8dc055831de9635e452467d0ed27ebccdfc938f83835d4230ef5e0f0
+EBUILD html5lib-0.999999999.ebuild 902 BLAKE2B 0a4eee9541b3e256195d15bd3fb9d39191fd9f8ee755da586e2438f1affa014d1ff9bfa352f90a634f809de038993127917b6b599ddc3e7ca6f96082e321a911 SHA512 4480b232359af5c515bb6e2dc78101438d3cc1595be883fad2b62fd9d94d6ca94fd1d3f465f45a50ea7cf485095d66a02badbf6b47adb28f40186cf2ece916ff
+EBUILD html5lib-1.0.1.ebuild 903 BLAKE2B f0164eb2731bcae07b5a04e8bacc67442a1c5283cb4777f99a284df2c1fe4cdd04dc2665232dcc9d7176231f9ca89790940fb19e7edc87a791b05dfa099448fe SHA512 8cfe02fb6da9678c475f3ea123f8038d3397b18d28b3dbd1a5384b79ed895633b44ef0fb4957e8dc8f9ba3029137593fa024050ec5cbd2c72560d302af015cf4
+MISC metadata.xml 589 BLAKE2B d98d80202c045607de5843e34313a06e9493c50bb1154e3f90a7c1c9236de2b4369827d35cb8540125524b54c0453ce56ca7ecf3a359bd9bab6e548ea1377f9f SHA512 b619c0adb0c781b00e656b1027465ec19d1ab7d0792475f197ab4164cb8a1c26563dcf48d147e346637789c8ec1603afaea428357c1022c42e22b85967e1694a
diff --git a/dev-python/html5lib/html5lib-0.9999999.ebuild b/dev-python/html5lib/html5lib-0.9999999.ebuild
new file mode 100644
index 000000000000..75af49a9d1ce
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.9999999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://github.com/html5lib/html5lib-python/issues/224
+ # https://bugs.gentoo.org/show_bug.cgi?id=571644
+ has_version =dev-python/lxml-3.5.0 && \
+ einfo "test are broken with dev-python/lxml-3.5.0" && \
+ einfo "https://github.com/html5lib/html5lib-python/issues/224" && \
+ return
+ nosetests --verbosity=3 || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/html5lib-0.999999999.ebuild b/dev-python/html5lib/html5lib-0.999999999.ebuild
new file mode 100644
index 000000000000..6d7903ac144e
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/html5lib-1.0.1.ebuild b/dev-python/html5lib/html5lib-1.0.1.ebuild
new file mode 100644
index 000000000000..198ea67b7174
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~mips ~ppc ~ppc64 sparc x86 ~amd64-fbsd ~x64-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/metadata.xml b/dev-python/html5lib/metadata.xml
new file mode 100644
index 000000000000..a9695174a877
--- /dev/null
+++ b/dev-python/html5lib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ html5lib is a pure-python library for parsing HTML. It is designed
+ to conform to the WHATWG HTML specification, as is implemented by
+ all major web browsers.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">html5lib</remote-id>
+ <remote-id type="github">html5lib/html5lib-python</remote-id>
+ </upstream>
+</pkgmetadata>