summaryrefslogtreecommitdiff
path: root/dev-python/html5lib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/html5lib
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest3
-rw-r--r--dev-python/html5lib/html5lib-1.1-r1.ebuild39
-rw-r--r--dev-python/html5lib/html5lib-1.1.ebuild4
3 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
index eb1e328bbd38..cf1d26158f45 100644
--- a/dev-python/html5lib/Manifest
+++ b/dev-python/html5lib/Manifest
@@ -1,4 +1,5 @@
AUX html5lib-1.1-pytest6.patch 7489 BLAKE2B 73117fe1e75647760d8ccaa7296b8726d88dc11252d1dd23f3dc60ce28d7fc86dd724b6ee1e6756f937eb78ea7f684a1be9ab0783621971d252fb1f4b8fbae75 SHA512 d1a8642381bafb00f7b682ae35a01168731893e44ae3509ac36d3bc1d65ea48e32099447de9c09113da4ba1d0b6f969260c199c056f145295caf1bf985dc8a54
DIST html5lib-1.1.tar.gz 272215 BLAKE2B 11a4fc3fb84bf8bab4af5da1de30b0892a9eb454505716b3db391187053c9aac159b1c82ae787896592b8fc850363bba9313b9d7fc617150771c3bfa1aeadefb SHA512 af7c29591007fded99be6c38e3d0ae5a4ac32d71d26046a615918ae732cb1c1ecbf754f47ceca1a53726c3843f3ecea7af87a7362281b45ff3af495815818626
-EBUILD html5lib-1.1.ebuild 800 BLAKE2B eb64baafc106f735315b0524f4e2fd163094f11ea66ca03f671b80ac0fc4f014299ca7438677f2ce173328c1fba0674df0d05d28246b2e8bf36c41d922bfb7f1 SHA512 30022083d77663113b07dd4dcae368e79b914e02dc8cc9d2b9246fda8a186b5c851f5a26a2954153965b176b8b76fd26b1d5ff8584450111b8105ce851f1ad44
+EBUILD html5lib-1.1-r1.ebuild 891 BLAKE2B df9c20fbe94056fe7a336f61a001e2ad72834163a3501c287f001d3c2d4375da3a5164b26d14930dd98f99696fcc5d8a58126a18c6be939012d5bca8009eea5c SHA512 410fecaff41dd622f030623eaf6fd99d572e09e9fe583cb0be84f2f817ae48ef52957ebf482d15ac67ca5b3e389fd3ff294a2c8fbef8b92fc73da817b7992b60
+EBUILD html5lib-1.1.ebuild 807 BLAKE2B 56d286728b74ef27b824899d8244816e676bbb954756d4ee8d2b138dfda8f4d34c671ab732f244dd71311927cf0a81545d14c299a24fed6f237b00e896a10eed SHA512 3e4c60803d424b2f7a78138db9014ebd7c0c1177b846117fd064e5472bb3634b6da42a5cdfddfc49fd41419693af63d38c69eb803a3cb85ba167bb9285a686a3
MISC metadata.xml 615 BLAKE2B 534717ae2665116fbbac153e8fc0fbe00bdbfa85e499dd0b6ba904dd4f901e5b68260c560ca324668db56c5037c2a6fcb02736627445d1a9385a1304248ae5d2 SHA512 88059bef419527523f3e7d6a7ad12bc54cf45cbc4b634e73524bdd94afb7d4c3b6ef684cad8649975e4a705d52f382a3f0e9860bb0378fbcadc0024c30071ca1
diff --git a/dev-python/html5lib/html5lib-1.1-r1.ebuild b/dev-python/html5lib/html5lib-1.1-r1.ebuild
new file mode 100644
index 000000000000..aeddc5a97e76
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="
+ https://github.com/html5lib/html5lib-python/
+ https://html5lib.readthedocs.io/
+ https://pypi.org/project/html5lib/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest6.patch
+)
+
+RDEPEND="
+ >=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/html5lib/html5lib-1.1.ebuild b/dev-python/html5lib/html5lib-1.1.ebuild
index 18e0d1b351b5..06de5ac56d59 100644
--- a/dev-python/html5lib/html5lib-1.1.ebuild
+++ b/dev-python/html5lib/html5lib-1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
PATCHES=(
"${FILESDIR}"/${P}-pytest6.patch