summaryrefslogtreecommitdiff
path: root/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild b/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..39204b859065
--- /dev/null
+++ b/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast C based HTML 5 parsing for python"
+HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2:=
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # Soup is not used when lxml is available.
+ rm test/soup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}