summaryrefslogtreecommitdiff
path: root/dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
commit867ef65cd897014478ed65034b1ac3f139289a77 (patch)
tree3af9d9e893bca02bb644786f42dfaf2678d6908d /dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild
parentf077c725ef746943ec7902350b30ff569f5995ba (diff)
gentoo auto-resync : 08:11:2022 - 15:24:16
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild b/dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..211165d5baa8
--- /dev/null
+++ b/dev-python/html5-parser/html5-parser-0.4.10-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Fast C based HTML 5 parsing for python"
+HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="dev-libs/libxml2:="
+RDEPEND="${DEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # Soup is not used when lxml is available.
+ rm test/soup.py || die
+ sed -i -e 's:-O3::' setup.py build.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+}