summaryrefslogtreecommitdiff
path: root/dev-python/hpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hpack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest5
-rw-r--r--dev-python/hpack/hpack-2.3.0-r1.ebuild39
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild41
-rw-r--r--dev-python/hpack/metadata.xml23
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
new file mode 100644
index 000000000000..79b48e492957
--- /dev/null
+++ b/dev-python/hpack/Manifest
@@ -0,0 +1,5 @@
+DIST hpack-2.3.0.tar.gz 41610 BLAKE2B 65fe4f07f64dddff5b24b3a84f7e49de32e358fa59bb1b21e619135ef33d282d4cd24283e93c71bb71c89d7b5b2a3f8ed36f6d406751c54247472a75192bf50b SHA512 a3d13da105482bb258ee3a2314b2629215028777f84127f71359f08819c96af088a3952bb0a74435472035d10ee6e3943cdad689a28f04cbc12cddcc4af9a8a7
+DIST hpack-3.0.0.tar.gz 5305971 BLAKE2B d1df8a1b2a1ce8b91e63cab475d3957f937fb74c0bec343d342971be1bb7cfbc929c53cf041845df2965cef0cfb098345bf0612acabc7ef3e5e23f6f0aa44f2f SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6
+EBUILD hpack-2.3.0-r1.ebuild 1038 BLAKE2B e97d4e530475ca6fea71a82f43a263430299d05f835e29c3c81b5f3fb0eb5cc6f61964399735c924ae55a5fb10987827da5507b45425512d8af7f9276ab99876 SHA512 9a62c4d1ed8669918aef7eb69eb30c9823cdd6155b3153705d2684cbea8baeebb947246e89612029105493ef62809b59be081d5a06c96675d27134e055a0408e
+EBUILD hpack-3.0.0.ebuild 1196 BLAKE2B cc038d197ee9e597859585c6ca32a9f0b173df78536b5f51c885b0da775f0f693f8f759b35864b3695870d2293e08518b943ffc6e4ca06b7d352a7dab57c754e SHA512 54fd91f2adb35e4f8a842db1ed0aece4e95cc5f47af8decc659616361a09dcbedcff428c08138429555827fae8d9d9eb89a3096362369167ab012643ab10b1c5
+MISC metadata.xml 755 BLAKE2B 07d55adb82a465399ac181c0bc57d6e884acc171eaf00ae4b32b1c7df02082a80e1904cca1755f755fdf3d7dee3028dfba951d7799485f43657c0141bc12c002 SHA512 0941a33f24de0db1f466447ba36585cd3d5dfa70eade8d076089cbe2309a7ac5498b77a712dc237f335a27c954b7b57be7c951c5a3c052b648499dbb545375be
diff --git a/dev-python/hpack/hpack-2.3.0-r1.ebuild b/dev-python/hpack/hpack-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..b110c9c4eb3d
--- /dev/null
+++ b/dev-python/hpack/hpack-2.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.org/project/hpack/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~sparc x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
new file mode 100644
index 000000000000..07eac8c2bbc1
--- /dev/null
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.org/project/hpack/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=""
+# dev-python/pytest-relaxed causes tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
diff --git a/dev-python/hpack/metadata.xml b/dev-python/hpack/metadata.xml
new file mode 100644
index 000000000000..d745e07486b5
--- /dev/null
+++ b/dev-python/hpack/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>cory@lukasa.co.uk</email>
+ <name>Cory Benfield</name>
+ </maintainer>
+ <remote-id type="pypi">hpack</remote-id>
+ </upstream>
+ <longdescription>This module contains a pure-Python HTTP/2 header encoding
+ (HPACK) logic for use in Python programs that implement HTTP/2. It
+ also contains a compatibility layer that automatically enables the use
+ of nghttp2 if it’s available.
+ </longdescription>
+</pkgmetadata>