summaryrefslogtreecommitdiff
path: root/dev-python/hpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hpack
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest6
-rw-r--r--dev-python/hpack/hpack-2.3.0-r1.ebuild39
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild39
-rw-r--r--dev-python/hpack/metadata.xml24
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
new file mode 100644
index 000000000000..b1c61f19aa7c
--- /dev/null
+++ b/dev-python/hpack/Manifest
@@ -0,0 +1,6 @@
+DIST hpack-2.3.0.tar.gz 41610 SHA256 51bd9aa8151efd190d70fe87991b1e3b79be0f93f0e34088fba2a8d34877a0a9 SHA512 a3d13da105482bb258ee3a2314b2629215028777f84127f71359f08819c96af088a3952bb0a74435472035d10ee6e3943cdad689a28f04cbc12cddcc4af9a8a7 WHIRLPOOL 8f47b6c2a78f915b009c35ecefa517486c27eb45f0b99834718152e14f9e934c23d52981c87b0c39af28fb9cb58d94e5eda07db2e999c37900b76b7aefd64b08
+DIST hpack-3.0.0.tar.gz 5305971 SHA256 0f8f5f92cfa59f91804eabb237d4b18895f3e200e282c41cedf6cd11a4416daa SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6 WHIRLPOOL 3252253a9f489d5bf4bc8ef243f576c99f5fa9a49d2767ca1e7f59ba15da1e00de3b083e6e64f69bb8c3c32bf27b177aaaad94b3cf1aba1c726d473d7b062403
+EBUILD hpack-2.3.0-r1.ebuild 1037 SHA256 54895f4391112a042e43e26d91f1d55d4194014d76132ceafda288b7a33e696d SHA512 f44d46b46f3cb4ef53e416b3d141fc3db00b304d5b79867848db10e8b0389f1a53b44464b782d360a7294c6d307cc9701e2c7799d16ad800c5e201a2909abe35 WHIRLPOOL 59e3ba9f8df693859fec946451069f1d0b710c92208e99b87255b26d69a4b37b293bdcc0c4016c8c98c0445c82a4744fa92889e0204e119b6320fc2287b3b7ea
+EBUILD hpack-3.0.0.ebuild 1077 SHA256 f9f6031f81ee5cb4636ca25e78dfc24f2eae5061a655be20bf89014eb33ad69c SHA512 2ce9835a2aa1f3eabf15f320ca34164f4007a3ba92ae7e316131bb5ef850f7d8814c3dd257466e32416a235fe9c8f65fd074241c8142954817f262b6bb30aa4e WHIRLPOOL 07ec571e523b8451c822d2822ed8438c1fd59f99bc5c4c26f4b04360e330638cbb3180978baacbf4a6277872b7d47b19730a474ed95d813e995621db959c86d5
+MISC ChangeLog 523 SHA256 f001fd94530baa2f45994b34c7612a68954b1a95826d1dba5629c2abf8f7a9d3 SHA512 cd250280a0008dbbe71f978165c7bce670c71e69177876fb64e87267726760dba4ef42debb3acfc51921d116d37462eb417f2455758158cc448bfeb110d5e5ea WHIRLPOOL 9714e0c8ffe42e81e7dd2c8131034963c143dbef8a4b739fa223d2ac58a6258c254d7881d4e885c0d76f937ee70108037b0a10c39d9858bd0314e0d651c496d3
+MISC metadata.xml 803 SHA256 1c1a3736c451f7ebceedc758010cd28721c9bfd0334f461da7c2026b0005eaf3 SHA512 b8ac20ddf96244080d349be25143b5fda799e158b16363aa23bc8b628e241fe7c8a32f8f281c91f56c80a7a91130640d922112f565c7dba470062ce97db528ee WHIRLPOOL 81c63dcf91a8f38a14015f5dcd5ca83997655ddfa73c831e27af1d0e0d8a63b7d76266c1c32546ddb4652bfdb1a1978f0ccc7914cb2b9eaf6d40971b4e873ed6
diff --git a/dev-python/hpack/hpack-2.3.0-r1.ebuild b/dev-python/hpack/hpack-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..cb4eb89e1531
--- /dev/null
+++ b/dev-python/hpack/hpack-2.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.python.org/pypi/hpack"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
new file mode 100644
index 000000000000..f4c42fd21be9
--- /dev/null
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.python.org/pypi/hpack"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
diff --git a/dev-python/hpack/metadata.xml b/dev-python/hpack/metadata.xml
new file mode 100644
index 000000000000..69a604fdc475
--- /dev/null
+++ b/dev-python/hpack/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>cory@lukasa.co.uk</email>
+ <name>Cory Benfield</name>
+ </maintainer>
+ <remote-id type="pypi">hpack</remote-id>
+ </upstream>
+ <longdescription>This module contains a pure-Python HTTP/2 header encoding
+ (HPACK) logic for use in Python programs that implement HTTP/2. It
+ also contains a compatibility layer that automatically enables the use
+ of nghttp2 if it’s available.
+ </longdescription>
+</pkgmetadata>