summaryrefslogtreecommitdiff
path: root/dev-python/hishel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 00:31:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 00:31:01 +0100
commit85e9aa4b6ca3ad1da1147e6d728e350e11266456 (patch)
treeb637dd642620d99909f84bd226fbf6baadf27ffe /dev-python/hishel
parentc510d9ec7aca9b092e381a7a4ff213757c7a9709 (diff)
gentoo auto-resync : 09:04:2024 - 00:31:01
Diffstat (limited to 'dev-python/hishel')
-rw-r--r--dev-python/hishel/Manifest3
-rw-r--r--dev-python/hishel/hishel-0.0.25.ebuild55
-rw-r--r--dev-python/hishel/metadata.xml12
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/hishel/Manifest b/dev-python/hishel/Manifest
new file mode 100644
index 000000000000..f7e741b821f0
--- /dev/null
+++ b/dev-python/hishel/Manifest
@@ -0,0 +1,3 @@
+DIST hishel-0.0.25.gh.tar.gz 825114 BLAKE2B dd7d7bec47700a1ab07976ba31b951adacf7e917dd7ba09419cc6e3b81f1b6609a1f7f14a6c176b0c151ed255cf099f3da60122717b2be9161bd41b7ba080f36 SHA512 16aec1ea495075b4932e1e9d16b07af060b49bb74faed097343bde99c5d2b656b36762b2f2d67fd46c31b700206eec77ecdfb364a1c2cd19bb67c3055abc9e98
+EBUILD hishel-0.0.25.ebuild 1611 BLAKE2B efc386f50eca4161cc3c6da7bcb7e3171bbaae9eb83d0ca48e9918fc5b0b9c07963547c00c21b98f67c286b8e1a76ac6cea419abfe8817cbf08020d8977bab20 SHA512 0bc674f0e7ffab7d6c464ca23e1d80c26e7a337f969d4f763c6fa4dfa82454f08934f96c5285c1e09983a3b26f2cad0299aa1ef83051f346aa47594540cff0b4
+MISC metadata.xml 378 BLAKE2B 24bb3b6d47931488021a625ac5f4eca9575efaebabc4af29fcd42ea8468a0a8da077d88b98c6f348c7528d7b338fbf553475894fe0726f11ca48c6c5d4720f61 SHA512 ae67451815773cffe43a0e16ae42020f1c29fb83ad711633666b065be586a08e4da5ebcee8e35d7f0c0084c018713760a1f20b4b9a7f2a5d43691589be357b42
diff --git a/dev-python/hishel/hishel-0.0.25.ebuild b/dev-python/hishel/hishel-0.0.25.ebuild
new file mode 100644
index 000000000000..5d674e566749
--- /dev/null
+++ b/dev-python/hishel/hishel-0.0.25.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="An elegant HTTP Cache implementation for HTTPX and HTTP Core"
+HOMEPAGE="
+ https://github.com/karpetrosyan/hishel
+ https://pypi.org/project/hishel/
+"
+SRC_URI="https://github.com/karpetrosyan/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests that need anysqlite
+ "tests/_async/test_storages.py::test_sqlitestorage[asyncio]"
+ "tests/_async/test_storages.py::test_sqlitestorage[trio]"
+
+ # tests that need a running redis instance
+ "tests/_async/test_storages.py::test_redisstorage[asyncio]"
+ "tests/_async/test_storages.py::test_redisstorage_expired[asyncio]"
+ "tests/_async/test_storages.py::test_sqlite_expired[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage_expired[asyncio]"
+ "tests/_sync/test_storages.py::test_redisstorage[trio]"
+ "tests/_sync/test_storages.py::test_redisstorage_expired[trio]"
+)
+
+python_prepare_all() {
+ sed -e 's:mock_s3:mock_aws:g' \
+ -e '/import anysqlite/ d' \
+ -i tests/_async/test_storages.py \
+ tests/_sync/test_storages.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/hishel/metadata.xml b/dev-python/hishel/metadata.xml
new file mode 100644
index 000000000000..5cf037972bfe
--- /dev/null
+++ b/dev-python/hishel/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">hishel</remote-id>
+ <remote-id type="github">karpetrosyan/hishel</remote-id>
+ </upstream>
+</pkgmetadata>