summaryrefslogtreecommitdiff
path: root/dev-python/hishel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/hishel
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/hishel')
-rw-r--r--dev-python/hishel/Manifest2
-rw-r--r--dev-python/hishel/hishel-0.0.30.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/hishel/Manifest b/dev-python/hishel/Manifest
index 52cf90c77595..929cb3124114 100644
--- a/dev-python/hishel/Manifest
+++ b/dev-python/hishel/Manifest
@@ -1,3 +1,5 @@
DIST hishel-0.0.29.gh.tar.gz 828680 BLAKE2B 2869f53e04e92d5c6ccaeb3234a299a075db8429b3b8f77ac9671764b65a4a7d360451e934651789caf2e654b3e5b18819b741b52abe89867157599b921d5a40 SHA512 a16b2c198ea93c2445e0f572e5432c1f44b12ed0e301e52ed46c2c849a5a324457f88ca50c5e98283ceb9aaddf1e1ea4a11644cf61dd0ca4a25f956950c6da23
+DIST hishel-0.0.30.gh.tar.gz 832978 BLAKE2B 932150b3464dcbc4fc2ff1361bafa6b2ea3fef496b0c89117c18b62122d07b0d71db66762e3eb87edb03f84eb4af0273f1792131e110291924bb29299051741a SHA512 f55f04badfe9ea161e20d8eca631cc02f9b1195ddaf3ba75b5e1a0ef143337a13438181ede9c853f30f7a24d3b6e59cffdc044860fc564d18392a59bd603c5c9
EBUILD hishel-0.0.29.ebuild 1673 BLAKE2B 2a77c164dc91b43c6c91fcbd3a28e5ee2c5631cab2e87c4f7686410cd8a057bdb109b6cbc6de9092e377e1febe574429ec400cbf03c3ee8a69f05bd14b022209 SHA512 bccffd94791ab6a99a9e79af2cf67ca556ee2ad4f133f417192c57cdafd1ed4f918bcabb98d82c6c90386670f9f6f1c96bfb4120f7f85fdc8fe9a78395c19fd6
+EBUILD hishel-0.0.30.ebuild 1673 BLAKE2B 2a77c164dc91b43c6c91fcbd3a28e5ee2c5631cab2e87c4f7686410cd8a057bdb109b6cbc6de9092e377e1febe574429ec400cbf03c3ee8a69f05bd14b022209 SHA512 bccffd94791ab6a99a9e79af2cf67ca556ee2ad4f133f417192c57cdafd1ed4f918bcabb98d82c6c90386670f9f6f1c96bfb4120f7f85fdc8fe9a78395c19fd6
MISC metadata.xml 378 BLAKE2B 24bb3b6d47931488021a625ac5f4eca9575efaebabc4af29fcd42ea8468a0a8da077d88b98c6f348c7528d7b338fbf553475894fe0726f11ca48c6c5d4720f61 SHA512 ae67451815773cffe43a0e16ae42020f1c29fb83ad711633666b065be586a08e4da5ebcee8e35d7f0c0084c018713760a1f20b4b9a7f2a5d43691589be357b42
diff --git a/dev-python/hishel/hishel-0.0.30.ebuild b/dev-python/hishel/hishel-0.0.30.ebuild
new file mode 100644
index 000000000000..046e93ae7033
--- /dev/null
+++ b/dev-python/hishel/hishel-0.0.30.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="An elegant HTTP Cache implementation for HTTPX and HTTP Core"
+HOMEPAGE="
+ https://github.com/karpetrosyan/hishel
+ https://pypi.org/project/hishel/
+"
+SRC_URI="https://github.com/karpetrosyan/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-db/redis
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:mock_s3:mock_aws:g' \
+ -e '/import anysqlite/ d' \
+ -i tests/_async/test_storages.py \
+ tests/_sync/test_storages.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # tests that need anysqlite
+ tests/_async/test_storages.py::test_sqlitestorage
+ tests/_async/test_storages.py::test_sqlite_expired
+ tests/_async/test_storages.py::test_sqlite_ttl_after_hits
+ )
+
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Starting Redis"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}