summaryrefslogtreecommitdiff
path: root/dev-python/hiredis/hiredis-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/hiredis/hiredis-1.1.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/hiredis/hiredis-1.1.0.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-1.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/hiredis/hiredis-1.1.0.ebuild b/dev-python/hiredis/hiredis-1.1.0.ebuild
new file mode 100644
index 000000000000..a909b3a56dd7
--- /dev/null
+++ b/dev-python/hiredis/hiredis-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/pietern/hiredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="system-libs"
+
+DEPEND="system-libs? ( dev-libs/hiredis:0/0.14 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use system-libs && PATCHES+=(
+ "${FILESDIR}"/${PN}-1.0.1-system-libs.patch
+ "${FILESDIR}"/${PN}-1.0.1-api-0.14.patch
+ )
+ default
+}
+
+python_test() {
+ cd test
+ "${EPYTHON}" -m unittest reader.ReaderTest || die "tests failed"
+}