summaryrefslogtreecommitdiff
path: root/dev-python/hidapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 00:00:11 +0000
commitca7fcaa76aaf1f94284894a8d9a01bb153e80b11 (patch)
treedcfb443cd20285c353c22c05f43f96ca3d3161a8 /dev-python/hidapi
parent150a86a9cb006b4800d6517d58532b8a556fec1e (diff)
gentoo auto-resync : 20:01:2023 - 00:00:11
Diffstat (limited to 'dev-python/hidapi')
-rw-r--r--dev-python/hidapi/Manifest2
-rw-r--r--dev-python/hidapi/hidapi-0.13.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
index cb378d9d20fa..58ce9c3b2948 100644
--- a/dev-python/hidapi/Manifest
+++ b/dev-python/hidapi/Manifest
@@ -1,3 +1,5 @@
DIST hidapi-0.12.0.post2.tar.gz 125008 BLAKE2B 6792d8a4bbd80da19b3dd1fde47061e3a0f00678059e36598da4a34142cbfe1e732854c2a372a869891be79e1131a7cef138913556159574f10b8b08439bfefe SHA512 dee9f1f07e4f297b935c8e3fbe798471f449f6a101d68131db23d24ccfb5ce445cc3b0e7305606d3630443a817aa75a27093109078735168a59d21614606f0a0
+DIST hidapi-0.13.1.tar.gz 130169 BLAKE2B 127e622e4b85880f1c20ccb819b806c66357d8cfa6c15d370c13a6a0a3838ac6acf0673c7edbf5309a91f55051b6177800328b8f897ff43cd1e0af1b511c52a6 SHA512 8e6a7a6bf47e24f6f637cc036dc306518d893fc9fdf94639f626725e8f8767d7e85496d8db5f9f394d648ef5af4dd5ead0f0a6d452a019b5d9fa0716371febed
EBUILD hidapi-0.12.0.2.ebuild 706 BLAKE2B 3e5fdd69295c3667b5bcf0e76a812ff24606d4659d52a7abbcc4de2373d48a29f9cc5dd692dbc5f4d17360d1f49eef8576a70f4d8072a6445689cf8fc4aa5414 SHA512 be78d7ed014703b85984c1e44ffa5cc3fd16915528d94902b1d6e8fb28cf039a3ceb1956c30a5acab8753683a20bafa4524afa3a3fb2d51bd090246faf819f77
+EBUILD hidapi-0.13.1.ebuild 737 BLAKE2B 2374ac8d84b11ecf424759ce116b159aea6c16fa41771760c94fdcb990ceb9e69065ae9034fbc45ed8b5f486ad187004573923539a7e3283d2f899171968ef23 SHA512 b0628f644067a7403e44bbfbd07e7a5683462b388a9675e72131bf55213fa94d1df4292ef8ae4ab1c836c1d3a23a00398ebb869ba131ea375c3b3a6c846f5b41
MISC metadata.xml 391 BLAKE2B 29af920e7a546041fbd5e3fb8c28c07500eb7b306d2101716f2ce2190f76fa60c98f116b8e63a99e83d539a989ac49f64edd5b6c4d16be8849f98a0bd0f1d79f SHA512 06933868b65e5840d1bbd3913c2d863c92b18e9521e98f2a77813eb8da5e3b3c66f5571883fe2ccb6e717ef87df5f2e4992e0c12c9ff44d5c2fd1195dd8dd08a
diff --git a/dev-python/hidapi/hidapi-0.13.1.ebuild b/dev-python/hidapi/hidapi-0.13.1.ebuild
new file mode 100644
index 000000000000..fe4ec8ca7aa0
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Cython interface to HIDAPI library"
+HOMEPAGE="https://github.com/trezor/cython-hidapi"
+MY_PV=$(ver_rs 3 .post)
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="|| ( BSD GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=">=dev-libs/hidapi-$(ver_cut 1-3)"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_configure_all() {
+ DISTUTILS_ARGS=( --with-system-hidapi )
+}
+
+python_test() {
+ epytest tests.py
+}