summaryrefslogtreecommitdiff
path: root/dev-python/hidapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 22:49:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 22:49:20 +0100
commit6cef603bfc4353c863a1a0b460a0aa882d2dc51c (patch)
tree1df444f2d99f097ae87a3481221283e70dec2163 /dev-python/hidapi
parentb33c907ab2c29be7bd04369bc2e3f5dd0b109697 (diff)
gentoo auto-resync : 30:08:2022 - 22:49:20
Diffstat (limited to 'dev-python/hidapi')
-rw-r--r--dev-python/hidapi/Manifest3
-rw-r--r--dev-python/hidapi/hidapi-0.12.0.2.ebuild32
-rw-r--r--dev-python/hidapi/metadata.xml12
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
new file mode 100644
index 000000000000..81ae00b50540
--- /dev/null
+++ b/dev-python/hidapi/Manifest
@@ -0,0 +1,3 @@
+DIST hidapi-0.12.0.post2.tar.gz 125008 BLAKE2B 6792d8a4bbd80da19b3dd1fde47061e3a0f00678059e36598da4a34142cbfe1e732854c2a372a869891be79e1131a7cef138913556159574f10b8b08439bfefe SHA512 dee9f1f07e4f297b935c8e3fbe798471f449f6a101d68131db23d24ccfb5ce445cc3b0e7305606d3630443a817aa75a27093109078735168a59d21614606f0a0
+EBUILD hidapi-0.12.0.2.ebuild 701 BLAKE2B 9858592d4a703f4893765781562db912da7fa63d72657547e7dad2d9d4e7de9ba4b8842ce7f7593b68039a3a63c0b6f08e3a1569921b4f7e2128b9130e8d0ed7 SHA512 f80b3144faf230931f1dc18ffa92541ce99b559f52d36cbf519dc30e8a0199126c8c76560702e72d78fdb676213908cc6ff243624022f78770ec41d564974ac1
+MISC metadata.xml 391 BLAKE2B 29af920e7a546041fbd5e3fb8c28c07500eb7b306d2101716f2ce2190f76fa60c98f116b8e63a99e83d539a989ac49f64edd5b6c4d16be8849f98a0bd0f1d79f SHA512 06933868b65e5840d1bbd3913c2d863c92b18e9521e98f2a77813eb8da5e3b3c66f5571883fe2ccb6e717ef87df5f2e4992e0c12c9ff44d5c2fd1195dd8dd08a
diff --git a/dev-python/hidapi/hidapi-0.12.0.2.ebuild b/dev-python/hidapi/hidapi-0.12.0.2.ebuild
new file mode 100644
index 000000000000..5aa029943585
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.12.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Cython interface to HIDAPI library"
+HOMEPAGE="https://github.com/trezor/cython-hidapi"
+MY_PV=$(ver_rs 3 .post)
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="|| ( BSD GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=">=dev-libs/hidapi-$(ver_cut 1-3)"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_configure_all() {
+ DISTUTILS_ARGS=( --with-system-hidapi )
+}
+
+python_test() {
+ epytest tests.py
+}
diff --git a/dev-python/hidapi/metadata.xml b/dev-python/hidapi/metadata.xml
new file mode 100644
index 000000000000..59255f6b605d
--- /dev/null
+++ b/dev-python/hidapi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sultan@gentoo.org</email>
+ <name>Stephan Hartmann</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">trezor/cython-hidapi</remote-id>
+ <remote-id type="pypi">hidapi</remote-id>
+ </upstream>
+</pkgmetadata>