summaryrefslogtreecommitdiff
path: root/dev-python/hidapi/hidapi-0.12.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-python/hidapi/hidapi-0.12.0.2.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-python/hidapi/hidapi-0.12.0.2.ebuild')
-rw-r--r--dev-python/hidapi/hidapi-0.12.0.2.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/hidapi/hidapi-0.12.0.2.ebuild b/dev-python/hidapi/hidapi-0.12.0.2.ebuild
deleted file mode 100644
index 970476fad5c7..000000000000
--- a/dev-python/hidapi/hidapi-0.12.0.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Cython interface to HIDAPI library"
-HOMEPAGE="https://github.com/trezor/cython-hidapi"
-MY_PV=$(ver_rs 3 .post)
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="|| ( BSD GPL-3 )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-DEPEND=">=dev-libs/hidapi-$(ver_cut 1-3)"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-python_configure_all() {
- DISTUTILS_ARGS=( --with-system-hidapi )
-}
-
-python_test() {
- epytest tests.py
-}