summaryrefslogtreecommitdiff
path: root/dev-python/hglib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hglib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hglib')
-rw-r--r--dev-python/hglib/Manifest5
-rw-r--r--dev-python/hglib/hglib-1.5.ebuild37
-rw-r--r--dev-python/hglib/hglib-2.1.ebuild37
-rw-r--r--dev-python/hglib/metadata.xml19
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/hglib/Manifest b/dev-python/hglib/Manifest
new file mode 100644
index 000000000000..aec732e4133e
--- /dev/null
+++ b/dev-python/hglib/Manifest
@@ -0,0 +1,5 @@
+DIST python-hglib-1.5.tar.gz 27812 BLAKE2B 35a411f91d3e915d6679ada6ecd28798dad20a6082d74661168d15a084fb0482cba0623948fb5be38fc57a4b744a021ac10536ba75d230c493c0c1f1f7aaf8ca SHA512 2506e2ac95488830b90f5f099d231e45833a8f19ce14fc2f3391ae1bf48ca72187b6b57afb633ecbe6cd2c6f3d3f482d75e03ea36406b3a07085ed1b4ef9c6b5
+DIST python-hglib-2.1.tar.gz 29030 BLAKE2B 3603e4030baf1f542c7c4b2123a78e3567141af8e84709eca38495ecea264f85c870005b39f8fc1bb2afc611c9a2c428971c8d783bc2595e25d83b9fcb5a2af6 SHA512 82cd00e4184a8a002ea0bcc2dec4de06a705f5f6cecd1ddbddef08ead2817f673590884aee5187fbc3496ced3f27ca8c8d78e0436fb97205ef654cd28d912e68
+EBUILD hglib-1.5.ebuild 829 BLAKE2B c2b0714c99d8d6e40c152e255a2e8dabf3bd0c7443ec2c8be37f3a5067786f66d0a2b7cd350e0362eac8f0fb1896249b5aea63e3b6f19c8e10ae0f213b4e17e7 SHA512 360909ae97f2a2044844975d4e16eb33dd67aa34cb92a0d47f795d791917f9406c884ee9da89160dc6fd833b42b1410a5a300e740501699a07c06920937f8e5b
+EBUILD hglib-2.1.ebuild 839 BLAKE2B 24cdf270b6972b7d9ded4f9a7da71e5923b1c07fbc781ccf9aa717eecef448631aee41a6e7cb3c18cba9d7c1348a6f92a5ea10520fccd131ee8252fcf4a09eb9 SHA512 16fd3b7fe6379563c706d6a3b0403a19464c4adedd85f9bbe71800db07f7e64573dfb80fa88667f56777ed0ed5dd3bcc446e4ea4af15662aa9f1735caacf6a62
+MISC metadata.xml 554 BLAKE2B e418d3cddb3b00704b929f94523e09562a7b2c1e6fed7882ebaa034d11ab5034782d7d377438e7d519f78b89da7b07e3826b1f100b4722f6666cffa8b1b68d26 SHA512 421fa6d625b36970114ae407051d4363367d6a6a2e53cbd87a5a996ef23fdfaeb489342fc8af6e64aa074640b088097ea54397ff09351a6902fc502c5d1146bc
diff --git a/dev-python/hglib/hglib-1.5.ebuild b/dev-python/hglib/hglib-1.5.ebuild
new file mode 100644
index 000000000000..8e38d45dd8cd
--- /dev/null
+++ b/dev-python/hglib/hglib-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="threads(+)"
+
+MY_P="python-${P}"
+MY_PN="python-${PN}"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-vcs/mercurial-2.4.2"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ if ! ${PYTHON} test.py; then
+ die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/stats.py )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/hglib/hglib-2.1.ebuild b/dev-python/hglib/hglib-2.1.ebuild
new file mode 100644
index 000000000000..b2b3105058e9
--- /dev/null
+++ b/dev-python/hglib/hglib-2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+MY_P=python-${P}
+MY_PN=python-${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-vcs/mercurial-2.4.2"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ if ! ${PYTHON} test.py; then
+ die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/stats.py )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/hglib/metadata.xml b/dev-python/hglib/metadata.xml
new file mode 100644
index 000000000000..5d827767bef9
--- /dev/null
+++ b/dev-python/hglib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arne_bab@web.de</email>
+ <name>Arne Babenhauserheide</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-hglib</remote-id>
+ </upstream>
+</pkgmetadata>