summaryrefslogtreecommitdiff
path: root/dev-python/helpdev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /dev-python/helpdev
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'dev-python/helpdev')
-rw-r--r--dev-python/helpdev/Manifest3
-rw-r--r--dev-python/helpdev/helpdev-0.7.1-r1.ebuild33
-rw-r--r--dev-python/helpdev/metadata.xml1
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/helpdev/Manifest b/dev-python/helpdev/Manifest
index 0045314013fc..4ded7125e18c 100644
--- a/dev-python/helpdev/Manifest
+++ b/dev-python/helpdev/Manifest
@@ -1,3 +1,4 @@
DIST helpdev-0.7.1.tar.gz 51575 BLAKE2B b780513c8b7af12296c003360c5805e8414e5c82fe459ab1e4ccaf68c9f029c817a6cb86535d26ad0143ea7dc60fb86126f6d87d4a84e85a9b29a9dbe651e2c8 SHA512 ba0af843617c7cc69aae2bfe88d437e90df14afa90dd0a76c0e7c1062f03963270514ff7653c859a70caec0cde3cc3f18ca87573fdb6a1d5e2fd5874cc24e59e
+EBUILD helpdev-0.7.1-r1.ebuild 715 BLAKE2B 59a9a327cfd1cdbb3bfea97ed8ab24922897d82b36353abec27532c8ff86de47a29b14c833b8a8a2c48fde6eefbbf9d02b8897d0ca8436607ba6d3cc3d2fe07d SHA512 17d4606952210943ef3959501487511fe21c145c901c93bc0f0598144c47c0a9f55ae40957eca75fdcc786b40e655f687393db28120751756ada4a9d4baf7400
EBUILD helpdev-0.7.1.ebuild 680 BLAKE2B 71502b7950106d39dcb2f964aa848c0064abb611c11a1d8935e5dcb32b6c5152cee0715fe34077f5309de21987673e19394b9821756c798ff301c20047d83e2f SHA512 44fcd4452a79530f6242c00603f90314b14348b18ead41b9637f4aa06a57862e3eea23cfaa0f049ab340a434235983f592f95f3e6d8981626adf71d04fe5c3d9
-MISC metadata.xml 353 BLAKE2B 3d959283a5aea52d6387e26f476e53bdca58e5414233dec3a9e8925ae9da0f99818b7a74f5e494cc1983f725ebdd98b7a16a87d3c65c614f716257dab4757a94 SHA512 16990f134dde3547be222021e39f32dd7d1710d02a19520a5048c4df8fa910d88c4d9ef598b2187914e466bebe0000c060f0474bf0ecd5f9cb04aeed64a1cad1
+MISC metadata.xml 409 BLAKE2B 722b41aeba000d0f36882bf6ae5965342f2b292c0c42ca36f1fe38a681d5ca72f8bdd3c86d9b1f99dc4005e91b3cf4b1d047b211ced155918293358ccd75fdfb SHA512 84f64156602ee268040877e421a8fdb45e417ef218609b7134d32e3f74f210e06c7f84e0059b15d8f2c908140c8decf0d1a66ef4d2a6148077a42b4337de8f7e
diff --git a/dev-python/helpdev/helpdev-0.7.1-r1.ebuild b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..06bea21ab338
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
diff --git a/dev-python/helpdev/metadata.xml b/dev-python/helpdev/metadata.xml
index a3fa11d7a3f7..f7e675703673 100644
--- a/dev-python/helpdev/metadata.xml
+++ b/dev-python/helpdev/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">helpdev</remote-id>
+ <remote-id type="gitlab">dpizetta/helpdev</remote-id>
</upstream>
<stabilize-allarches/>
</pkgmetadata>