summaryrefslogtreecommitdiff
path: root/dev-python/healpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/healpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/healpy')
-rw-r--r--dev-python/healpy/Manifest5
-rw-r--r--dev-python/healpy/healpy-1.10.3.ebuild38
-rw-r--r--dev-python/healpy/healpy-1.11.0.ebuild43
-rw-r--r--dev-python/healpy/metadata.xml17
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/healpy/Manifest b/dev-python/healpy/Manifest
new file mode 100644
index 000000000000..e55e1bc87144
--- /dev/null
+++ b/dev-python/healpy/Manifest
@@ -0,0 +1,5 @@
+DIST healpy-1.10.3.tar.gz 4018897 BLAKE2B c736e4cd445d51af55b76533dc2090e7926907ba9ccefc04d60576047c72e39e93c532980e24af10d548954c4bd5d580a16a3601a675eb0d7d965e3a8d1df4ba SHA512 c5862fceb597ffbc5c53204479fa9dba19287e3c08744e25edef3eaecfa726e61e8558d50d73e2bf4d19b7d0adc0ac928a38c4808fc92fe855f5eae101e18baa
+DIST healpy-1.11.0.tar.gz 4033412 BLAKE2B 3b0631eca53ab9798cf03b9f66ea9bcf1f2df16f3639fca353a14204e566027e37419e27f07a579f3cd7b05c4eea84160f4aefc5f9706e1ffbc553db68d8cf90 SHA512 35926c769f2fd4ebc3cd61357d742e9e1747325187e465bd3be62b4281506bd02cf3d8b982583819219e994dfa3936d6bc61914218325bb6b4ddfcffc50c802f
+EBUILD healpy-1.10.3.ebuild 953 BLAKE2B 5725c5958b90c0a5511280fc0324b07be79d4152b727045b7fc5e6d53431921e2a10ad00a63347d1df85643f220c44924c099cc0b61546e79a0139630ae07f6a SHA512 3bfa350217f621fd59ed84a95cde8f6dc452304228459f53d201fb2b75db2f78912d622ebe8e8376220e8f09a323c9500405165ccf485a9df46716b36606fe13
+EBUILD healpy-1.11.0.ebuild 1048 BLAKE2B 6d0ca3cef70a0dc8d7e03a38a8f9698e574b2dc249bafe7c79b1eb61f46b1ec76b5dcfd913a13c695b7653331427bdb03a467fadb24202a037e05ff3a723e1f5 SHA512 92ab0e948a8717f4e6be8f1164c46a974707a5e19311908f3519336adf37e8006f23d210479554ee4002f6762dc202f2cb52ca8367aadd620e001d30226a0616
+MISC metadata.xml 609 BLAKE2B ddd0006b243a7d1cbaab4d33d2b642b967edff7fafb729fe5715984aa36a6ed22f1ce11e6c0e566d7e0b3a1d2a437a2fa9ddd923ef61f26229c0665c58160635 SHA512 e8d86f81b4a62f3f15bb2210cfbc9eb51568525349c34e10bc32de76654f18c7937ee1c5390915c8a225be35baefb8b45d8cb982a41e314da77b91c30ae8749f
diff --git a/dev-python/healpy/healpy-1.10.3.ebuild b/dev-python/healpy/healpy-1.10.3.ebuild
new file mode 100644
index 000000000000..f84e392eec9a
--- /dev/null
+++ b/dev-python/healpy/healpy-1.10.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}
diff --git a/dev-python/healpy/healpy-1.11.0.ebuild b/dev-python/healpy/healpy-1.11.0.ebuild
new file mode 100644
index 000000000000..c517d95ea5cf
--- /dev/null
+++ b/dev-python/healpy/healpy-1.11.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}
diff --git a/dev-python/healpy/metadata.xml b/dev-python/healpy/metadata.xml
new file mode 100644
index 000000000000..39b8f2351616
--- /dev/null
+++ b/dev-python/healpy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Healpy provides a python package to manipulate healpix maps. It is
+ based on the standard numeric and visualisation tools for Python,
+ Numpy and matplotlib.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">healpy</remote-id>
+ <remote-id type="github">healpy/healpy</remote-id>
+ </upstream>
+</pkgmetadata>