summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-python/hcloud
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-1.27.2.ebuild49
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index b8a87b3ea824..d44953b4b02c 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,5 +1,3 @@
-DIST hcloud-python-1.27.2.gh.tar.gz 103273 BLAKE2B bcf82985882e5f5843e88989081d7c5acb4967f62829d96b121231a36326059f7f05b8b03de91b0d93c571ad576524c85b1987c6afcc18b6e9191047e09e9ae0 SHA512 8e5a205aed572be042df9bbe1bfb188112bc1b08367875f6da1d258e27686865a6e4d71e83697ad97ead4cb8879d4655363fa74b6f94d4b10ed21b2db1e7eda5
DIST hcloud-python-1.28.0.gh.tar.gz 106288 BLAKE2B 4ffdb81e82b51b85b0d52a938a24400b477850e3442c2565515c7ebbaa9b425d729d0caa269da502b3c5b24e5e3475d5d6cd60e9a77a97c8e362087a4b11c01c SHA512 fe720cf5b943f9535143f9389dc30e92ef295b7e5769b91e41ef979a5f6bbd059b42551818e7900e37213b530084eda51a54bad84a7ceb6e29f7f03d19bd4bbb
-EBUILD hcloud-1.27.2.ebuild 1131 BLAKE2B 635b12b80f9609d9c911a2d5bad3b082f1496d9e1cca1b2fd7429913f1d67508b4fa7532653433121aec6e315faca5b6b3e14ed48fe18c2ecd096c5ae4dcd708 SHA512 deb6df221c879f66c16ce9882f01b47bb67dd73bd24d15569580d7c6c16bd7e369692cb13125fcd38cfba403e7dd1de9bcaee5a5794db188d7e427f3bbde03f7
EBUILD hcloud-1.28.0.ebuild 1131 BLAKE2B 635b12b80f9609d9c911a2d5bad3b082f1496d9e1cca1b2fd7429913f1d67508b4fa7532653433121aec6e315faca5b6b3e14ed48fe18c2ecd096c5ae4dcd708 SHA512 deb6df221c879f66c16ce9882f01b47bb67dd73bd24d15569580d7c6c16bd7e369692cb13125fcd38cfba403e7dd1de9bcaee5a5794db188d7e427f3bbde03f7
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-1.27.2.ebuild b/dev-python/hcloud/hcloud-1.27.2.ebuild
deleted file mode 100644
index 618acc93c166..000000000000
--- a/dev-python/hcloud/hcloud-1.27.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=hcloud-python-${PV}
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="
- https://github.com/hetznercloud/hcloud-python/
- https://pypi.org/project/hcloud/
-"
-# sdist is missing doc assets as of 1.19.0
-# https://github.com/hetznercloud/hcloud-python/pull/183
-SRC_URI="
- https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/myst-parser \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- tests/integration
-)
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}