summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 13:50:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 13:50:54 +0000
commitaec6329fe6b56821fd643ccaacb4d5d61f4eaad6 (patch)
tree8c6e7db4b9a4a624121681a167e21bda8e3cfeec /dev-python/hcloud
parent0c8ede87a5d0aa1ec25364a435296ec7aa8b9634 (diff)
gentoo auto-resync : 20:12:2023 - 13:50:54
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-1.33.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index f054170179a3..10a5bcd1d425 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.32.0.gh.tar.gz 109858 BLAKE2B 7e242a92c81278facd7f9d2042d2d36787153215a72e97da7616f7d6b6ca6c06fadfd6b33bdab3699a8d8ac6ec1d7327b78a224a3f674a13a7d06791e91d4658 SHA512 013cd3a7e54b12348e4ec87e489b461c41822a85cd9fafc4421a8bb404ecf1fa079d99217db5f770e893ab9bb7223b588e4429968b8339b4d23654610dfa80c3
+DIST hcloud-python-1.33.0.gh.tar.gz 112726 BLAKE2B 9596564f80a27b5674d0dd8043c940aa927e44324ccac496d83aa665934729f949a96aba5b298540e7a1d083ce5739273cb28a3c37553f4609852c7a052c5363 SHA512 77a5799de30fc227be117e1dfaec3835ac5dbe00f47ee9b1a42b5164affc745d3317d612f8bfb58631fe757c59c4352cb96cfef38f94679af6f3fed03c117109
EBUILD hcloud-1.32.0.ebuild 1131 BLAKE2B 635b12b80f9609d9c911a2d5bad3b082f1496d9e1cca1b2fd7429913f1d67508b4fa7532653433121aec6e315faca5b6b3e14ed48fe18c2ecd096c5ae4dcd708 SHA512 deb6df221c879f66c16ce9882f01b47bb67dd73bd24d15569580d7c6c16bd7e369692cb13125fcd38cfba403e7dd1de9bcaee5a5794db188d7e427f3bbde03f7
+EBUILD hcloud-1.33.0.ebuild 1132 BLAKE2B 36c8da11a3c3e0a252a19fc9f62ac9baa408e6cfd28948cec5b0a490898702cb2885c5376b47a319c3ed9969ef38d9817449841ebcd50f5440865404627b3af1 SHA512 0181d301d65203d7fd0679a5a4973b5e264402b799f645c1dcafb6354fdea734e60858716c97690eb077ed222aa05532166d06b7f1273fd0a22b647583d9624a
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-1.33.0.ebuild b/dev-python/hcloud/hcloud-1.33.0.ebuild
new file mode 100644
index 000000000000..498400383d05
--- /dev/null
+++ b/dev-python/hcloud/hcloud-1.33.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}