summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
commitae832415103492f73a8351ed7a91cb596392d779 (patch)
tree50b8927d2d57e707e7e3402895a997ebbc349dda /dev-python/hcloud
parent77684468238b8755c1aa3e72f3055f4e62fcf14c (diff)
gentoo auto-resync : 21:03:2025 - 00:31:16
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-2.4.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index ee72e5a551c8..a7be1286fe43 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-2.3.0.gh.tar.gz 119846 BLAKE2B eab64db78ee9e5f33539142a869663d7a12cc08f25581a82e1d87d620452d1ce4877ff65654724f30ac602a7513e371f1f59455dcff5cdc2b94ba6751136d7b3 SHA512 8591b5406d51c8f71fdcb16bb423cc2317310484d3ef6a784d63fdb2dca9ec10d33a9fd6347f3c37e7a7c4772869a15013f8c6a83b5a2b867da0c41184c88d45
+DIST hcloud-python-2.4.0.gh.tar.gz 120779 BLAKE2B 9a81c91e7ddc90148b10ca370589e27cb06af9b8a7acff26979fa9ed4f4a095f0ebb458ba4b8223338d8c69123e0ca5763627a41a4d610786b2ac98594700098 SHA512 a22970ab1f1241368d424bc08d540da5f9287581d2a4ecdbba3feb7a97176ddafce66fc0397ee5e22b4131702cfabcab89347da3709a8b6d4d1aa71df001518b
EBUILD hcloud-2.3.0.ebuild 1131 BLAKE2B d48357b1df12bfc680b99f284e36cbff05ea7eda1da03ece87716892216d713586faf4c6666805adcd5f9064f939ec8eb9f62823e3dcf1208ccd935e535205b0 SHA512 54a16490b36d75bc840f7e567c7479af0a6237224626cd2d168053469e3242066690b5d6a4197440d09646a7b3602a75f2e1addce9c202a85b9e3b5f0a8dd439
+EBUILD hcloud-2.4.0.ebuild 1132 BLAKE2B 96cc86ea11eb2af773e8c3dcacaa1e1dfe83887d28c802a406e04e9184f127ea470746b60ebd535447d562a35fa900b34a48f4a1d6a696eb5a18cca1f451eb3d SHA512 045b980d9d981dfca5550f57802a7a9dae902251af980e9aee0a2f37651388dc35fd726551fcb8874df430d3b932090aaf89f1c0b102e1b66e7e7521ddabe90c
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-2.4.0.ebuild b/dev-python/hcloud/hcloud-2.4.0.ebuild
new file mode 100644
index 000000000000..00bab0f70422
--- /dev/null
+++ b/dev-python/hcloud/hcloud-2.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}