summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
commitebadb1bcdd3c4fdd2e1a569a04d2cd8c5049b64d (patch)
tree261a9ff495381f4023c98dfb4ecd5cb195b5f346 /dev-python/hcloud-python
parent2666e9c75caf914c25a25329523c982df8512930 (diff)
gentoo auto-resync : 28:12:2022 - 14:12:52
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 5cbe1f0b8c79..b63d63ee8ce8 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.18.1.gh.tar.gz 99042 BLAKE2B 159b2fb29021ca7993f75c4731867ed1bc57e2c9a3cf68a45acf43bb45e9a0862717907d1dfce45c960064ad82b71422e76b290db3516ea3744be95797db5e1e SHA512 6d172c214d25ae846b5561e4caa6b70d4f4e765e064ae971d5b216ceb743ab269f735e2c9adb68f1cf99ef429621b6998a34c8c7befa6d527dc3b774c0639bae
+DIST hcloud-python-1.18.2.gh.tar.gz 98998 BLAKE2B b4f8d3335c4589c8e5f453ed60299b222f002de1d8ae5ba95dcc35c6d4c4c4f649e6924037ed935651976fce06aa4ff61b893e3dcbdf745c6c1d9ff678b04dcd SHA512 da71f5590514d45b630662b1bedf7907e5ba33a48617131615377724e1377a2776f979c00e50521c513052b4f540224439e048e2e1215973b76c55a8a20e1a45
EBUILD hcloud-python-1.18.1.ebuild 954 BLAKE2B 5a189e7cb370de93dc1fb8b0d2d0d297d646b0da70cfef6ce17f66b63475f6ab1ba157945b0eb6e3877aec97c8db61c946c34950695f30da903c6aac20923fee SHA512 fd6013d779f6ea4647fdd3d975b4759e1812d27907cb4114a452e446a7417c8a9d5061da6a1af9c3f365e7c8cd3aa0ec03dc6dc45a249abe217453ab78a8e497
+EBUILD hcloud-python-1.18.2.ebuild 909 BLAKE2B 60605c00d247c20ef1623664bc1fc7e2b7f3b1b807c11bd1d93f65cbce89d61be7521f25ee58459ee810c27919e0ade4d43bd1065703d6179f82fbc1dda23675 SHA512 398a00fdf997f2d8dffd25ae41f7f516dcf7e7b13189dae3a6a0a47251f7780f0288a1bedc232360436b79bc9ff091e07e12d12c79ceca38f0d8d89f0cacc653
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild
new file mode 100644
index 000000000000..d120ee21e555
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="
+ https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}