summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
commite523ebcd50638ebe53f8f425d126bfa7385703b5 (patch)
treea8202f9224bd577afe09c919786f8836cf4a2a7c /dev-python/hcloud-python
parentd88834e7a12432c4e2d04ca7e938a66e25811f89 (diff)
gentoo auto-resync : 01:02:2023 - 15:05:01
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest4
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.1.ebuild41
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.2.ebuild2
3 files changed, 2 insertions, 45 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 7d846e877c2f..b31ef4512794 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,5 +1,3 @@
-DIST hcloud-python-1.18.1.gh.tar.gz 99042 BLAKE2B 159b2fb29021ca7993f75c4731867ed1bc57e2c9a3cf68a45acf43bb45e9a0862717907d1dfce45c960064ad82b71422e76b290db3516ea3744be95797db5e1e SHA512 6d172c214d25ae846b5561e4caa6b70d4f4e765e064ae971d5b216ceb743ab269f735e2c9adb68f1cf99ef429621b6998a34c8c7befa6d527dc3b774c0639bae
DIST hcloud-python-1.18.2.gh.tar.gz 98998 BLAKE2B b4f8d3335c4589c8e5f453ed60299b222f002de1d8ae5ba95dcc35c6d4c4c4f649e6924037ed935651976fce06aa4ff61b893e3dcbdf745c6c1d9ff678b04dcd SHA512 da71f5590514d45b630662b1bedf7907e5ba33a48617131615377724e1377a2776f979c00e50521c513052b4f540224439e048e2e1215973b76c55a8a20e1a45
-EBUILD hcloud-python-1.18.1.ebuild 954 BLAKE2B 8851a19b5ea4128e129b41d679a6b1f56b988d0225cfd45561d04c37898cc7e5140984d9e368beecf5746dd568b0753e3afce8007948ca5f2fcb1d6fc2fdb593 SHA512 00a35d5cf86591b5de9e2baa10d0a6f94d7aaa3749c9790bd647281ecad1403c9f70c78b988d203b4a19f674ac50646c680c0b1940d6175aaecb8a4568880f2a
-EBUILD hcloud-python-1.18.2.ebuild 909 BLAKE2B f2e1990c938d0ca74e55d2f2e28aeb6cf3663037e0a81e57c838a6a579292a46668f6066623bea2afe3d454e8a67b69203afc2a3cdbcf32fdf811ca45486b334 SHA512 6e99a0cdc92f2768953a6a0e4d67631417c62e74479b55e0d49150b97e8bd42f2c24d761232664b8be8c42a9578f44f84dd5bdaf84892880811c193ba8c82718
+EBUILD hcloud-python-1.18.2.ebuild 908 BLAKE2B d09128801fa2652dc3091a5ffa14328f0448227417cf8703d39eadd2697418ef3d44d0d7e17fb58ffee40aeab8aff198732a1ca47e61e42236737058e848c207 SHA512 31883b9eb3a7300ee426bdf745518c00189b715d7d62b64f5efd484709ef76ee8bae60ef2acc7d10e878e6b6b16338fc09dd154215540a4be66da6231e6b79f8
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild
deleted file mode 100644
index fe0571dbaf26..000000000000
--- a/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
-SRC_URI="
- https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- tests/integration
-)
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild
index 85299e1fcb4d..69b88e8e828f 100644
--- a/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild
+++ b/dev-python/hcloud-python/hcloud-python-1.18.2.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="examples"
RDEPEND="