summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/hcloud-python
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.10.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 57170bdba70a..44d592ef8fe5 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,3 +1,5 @@
+DIST hcloud-python-1.10.0.tar.gz 82155 BLAKE2B a22ad24863f416b039a04d9e82675fa7923303d73aff6045a2247fc755db1740cfd98418a84758a15eb96ff666bc6e395a969cf59a234571414087fb03cd533f SHA512 c16e070c39e514faf002f7c78ed8fca6ac762775a75bb1a04f3033f6cd9ca6424b595dbd636ad451bce1eb5b52214373ddd29513937c42c84b4a0a7d2e84fb3f
DIST hcloud-python-1.9.0.tar.gz 88885 BLAKE2B 455f955caddd8e72d02df57da2e08f395b9845f9658b73dd9f96b1fd73d7793fa13319d8365903599c000a803c9374dee7b50c5ad2a9ba449027d3dc602601fe SHA512 6da2a3eb7e4a4d7f13137167199f01f370210e6c139f0cd8a8e447ea3f14101d4b37b104ed387b1713ad62351ae72c8add7970e878571caa4242e6e347ef8833
+EBUILD hcloud-python-1.10.0.ebuild 1277 BLAKE2B ce85723c4555916561b612095e998e4c40f831fd4638041238cd436fab1c7e629ff14ec103262a8e969feeb043ca53689f08b8ad1d1a07ae85f284a5164b2f29 SHA512 b46383ba8af2d2a7741c8575f50620405bdaa4a2a5b40b7c73f96a74da067922cb0edc831f28de641500e2ebf3dde10227af1922d6469045e837f9d5dc366532
EBUILD hcloud-python-1.9.0.ebuild 1276 BLAKE2B 2088306a31ee63ceb9786443410cc49be7e78ac31aaa7dcba875da04071ff1718830276b8cd6e4e2ba9a301543d803329de75da1da2614d1b4fc32112442470d SHA512 00d995349df255a60a1263b3476a2bd23846cdfa00989baa71c7af5697748bcf504580f43f0c5ab255537e8ae8f77ee7a4f26978720b3d8a67e510369592fd52
MISC metadata.xml 347 BLAKE2B 4e9c42da7ff606982fb56c60b2eeb1315e862fbd2e55b28a46f8f86ff348fed8fd5a14843e8c41713267d16b378c2e317c672bd561056544dacdad8f09f54eff SHA512 f7a5d3297b23b097ca65415ca87441f9b14dee1f7be980b6bc7d747388fd511aadd12161f5785bbf3c97c3301487e0144fe11c40143ee8b25183c7f68a6d3c9b
diff --git a/dev-python/hcloud-python/hcloud-python-1.10.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.10.0.ebuild
new file mode 100644
index 000000000000..38732655eab6
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]"
+
+BDEPEND="${COMMON_DEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ rm -fr tests/integration
+ default
+}