summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
commitc17e7d2a8cc12551a02d28209cd2edbf078d5675 (patch)
treecde162c484c03f53827a78ec75a7f153d18933d3 /dev-python/hcloud-python
parent295483480d7b8ba2fff987fdd32eaa36fe730ce4 (diff)
gentoo auto-resync : 20:09:2022 - 11:23:36
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.17.0.ebuild45
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index e4a1c8e1aef4..c3f6e3fbc17b 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,5 +1,3 @@
-DIST hcloud-python-1.17.0.gh.tar.gz 98069 BLAKE2B b8fb2f1c4a3d139225a19599f956a845789872642bc62ec0434f5393e90f5ef64226b6363eeae0b3312084312aac4ddbe77e6e134b0502783e72568f23a71ee5 SHA512 829972585b5fe61aaaa2ee5294c97e6ad4a913229e8d87cec8e00d61480a780682b4eb75e2b9da5962bdb3dfda15b0a81afa74383be874e381a5f8e1a27d7014
DIST hcloud-python-1.18.0.gh.tar.gz 99047 BLAKE2B c32b048653bea1910ed8a82d0e08603a154dc89208c0cf8b9e046078277460fedffe6568c7c3cf56a8408bb0423d38464c4fd57dded4523886560823e3ee65da SHA512 8339b5da4df7f5e1f38fbd7a3f205387bfd7a65a7c4eaa757c4c35056b70c06230fe9b8a597b54bac082af975184bd5ef33a6e2747b60a67cc34d6771435452c
-EBUILD hcloud-python-1.17.0.ebuild 1002 BLAKE2B bd842b951fb091df46ed8c46b991bf25c3b029ff536f203ff125f49411e232eee8086a884eb236acb9060a68a54437e012fdb9ba0f2c4d83f785b317e4b4a5d1 SHA512 a0e3c143bb97edc7f36200cde2607c4aa93e3925328b1946701cb70712fe5d545516395572b799aa5c89932f30580a72ee70238f93b1dd2d69a06191c56f0250
EBUILD hcloud-python-1.18.0.ebuild 942 BLAKE2B 273b6e0a3dbb1d2d6d58d76a47e15c91f4bbd308f5229b50d108507541fb4dd2e15529356600e176e3050a9342820b785bd934c749514e0a9ad18f09e5bdaee1 SHA512 3b9854433067aa9e4835def83e102a2c49b58ccfc8420ba5aa23392e8964a3fc6195d702f5d452d0d0bd7faaace877a6cbd58ee26465132700743040f32edb5e
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild
deleted file mode 100644
index c429f98a9034..000000000000
--- a/dev-python/hcloud-python/hcloud-python-1.17.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
-SRC_URI="
- https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
-
-python_test() {
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- epytest --ignore tests/integration
-}