summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/hcloud-python
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.7.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index c2d354bbde91..0845c43c4d10 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,5 +1,7 @@
DIST hcloud-python-1.6.3.tar.gz 71575 BLAKE2B a6c969d713d1351bba0cebef8752abbbf0805b4a39eedc918767ccf60d590ac8259e1405a25c2c563923146d52ae1318d6362cbaee311bfe04bea5afcc18951b SHA512 dec3f16197de9f02c2707601e1cad40289d3ccbd6256887da50b84fb8fe6b0fb98f708c9ba0cfc2ff1308a53b9997cfda579df3ec79a1d28686a3c43f4124e74
+DIST hcloud-python-1.7.0.tar.gz 71683 BLAKE2B 43dfda161505d9aa486487a028dff9406e77f3c33efe935c13faf19503d1cd98a136703939408b0faf50633c1a40bbd5c43d90a6373acb38e8a0d61bf715a02a SHA512 d8fac8b74862d5f59f50ddac4f675c409f0bb5b51b16c6db094acae2323214c623bdb459c7fe0e74bb21fc88aa61e551b951cfa6c7de4504a4bf31c7f9481f2e
EBUILD hcloud-python-1.6.3-r1.ebuild 1222 BLAKE2B a5e15e7099d0a6a664be879f843bb028d4a5cbebf8b93a03e58c8ae6e5c40bdb7bc2eafd44ed7459437f3967a84f63fe08a58cc24d78fd0db9c085c28e95f4ba SHA512 831bfbd3736832e7a2d438aea92be8b9ada98f282665089c2d0f2998b184b4709b6a38a4248bbda16d11dbdb0997299f1a97dbafb1eecb200eec6ec04063c345
EBUILD hcloud-python-1.6.3-r2.ebuild 1268 BLAKE2B 849aeebb548c084de979afac89a1e4d73ca99e82edca878db75c1148426cd977ec0ce85c15204299f6465cfd9c9920a215b82df3ecf0e42db56acdfee38c7419 SHA512 48ff49f5db26fd81ce7c6a566b4dc24804b528653a42c361c5640e8e792318f0424e0ba27077a14c4bc6aae3994447f55878156c09403abd7f6eb1060a956ff9
EBUILD hcloud-python-1.6.3.ebuild 1028 BLAKE2B 6568a2dbd9928e71d4d92a1c15072b15fd77686b142aa0cc921755b604936c4f378d3feef37e0c2e6df7ea5ac196c7881cef73b3000d538fa236a474d98e699e SHA512 cb7879547643d1532988135b2c58f80bb99e6515c440ef6c8ff009d5505878890aaff48678c4bbc59c6b2226ddce0b474ebf2ac576c4cdcc37f63c41c1973e21
+EBUILD hcloud-python-1.7.0.ebuild 1414 BLAKE2B f869f16f112dc57f616728842e07abfc9f04bc64ae1c357dbc72632439eccfa1f5218ae2f6a2a35624b36cd52d519609479862aa4e443c8fb6cdc15bc8ec67c0 SHA512 20cf507235650b7a906c4084618a6b298820191fb3562663897cf121d0894a8197f77a9fa91837780303b1e4c135fe1768abf05845dde746b1fa939f621065a7
MISC metadata.xml 246 BLAKE2B 5439993f129fd56fc43062bce991abdd20627118aa0e723a343c721cbc910de4f8b7b34b6f1587acfe0a60d488d4b1d093c69eb7d78f6accade89bced7d69b93 SHA512 482630597bd2d56c1eaed7099225b4475aec8768e20bad70ea9d6b96791fa38359ba572ab9ad0fc7ea72f1ab736ed1e92fc3c156c3427b008c7220285edce11c
diff --git a/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild
new file mode 100644
index 000000000000..2f3b9f4100c1
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-2.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ <dev-python/requests-2.23[${PYTHON_USEDEP}]"
+
+BDEPEND="${COMMON_DEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme
+ )
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ <dev-python/future-0.19[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+distutils_enable_tests pytest
+
+src_test() {
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ rm -fr tests/integration
+ default
+}