summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/hcloud-python
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.6.2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index 179d0807c4ef..201ae944c086 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,5 +1,7 @@
DIST hcloud-python-1.2.1.tar.gz 63592 BLAKE2B 9a6d2dae97ff405ebd9b92bc833c9d953c13840e68be4eb43fed375a60e55cf4bf9b4b742b26fb03401f631b7f7127815961861cb673adf4839c829141c8ed00 SHA512 cb70d190350457fc3c6e474bc6c943070102762595dac2f386041956f64255f390a928a2f2411be861645cd65b015ab9e0c931b36aeed0076b06d9f67ac72d1c
DIST hcloud-python-1.6.1.tar.gz 71866 BLAKE2B 0a1d37d4dc8be4e28595385ec7622ec65367c40f9cdd455e03827a5ee2983f43026b1dbb7e9bd20d241ed9a4748015d33bdcb53b15ce148c401984960e158716 SHA512 0b2ecaa311b4dac44b3122a45a38f76f8377bc189b1550f21327ea3f56fefad624ea6809c4abd6bbaf5c8fc23dfa5e6edd352dcbbcfae6c87af897ff376ce2cf
+DIST hcloud-python-1.6.2.tar.gz 71887 BLAKE2B 2c423b0b83cc8c7bd5f0d4ef7db59516f125ff975e8cb82f38b340a0f448c20dd374a1edc7a486d18af3d438722b77f32f4ab6191966e3ada13f437f2d8a29a4 SHA512 ae2da263a038add593c7e302057d6e5e34258f180bddf67fc23edcc8c287c67d91aa190efeb1190af2596017b8964f4623d9cc03c4f1788c71c7d251f2a5422d
EBUILD hcloud-python-1.2.1.ebuild 1056 BLAKE2B 94a8aeb9cf22f4263222ab52e186c8604912c1a0931d96e3a47698019245d318753fc5d5686255fa0ef6f9460fe55a94b2125804407da5f94ca92f4577189a37 SHA512 ac4b6bb887fb0b1ff076c4ba02dd1a33256f238eab49f250db3b8a1908c68784dfe5c51b5dfa2b7db7f5dc57496e472c8be8d50d152392984c2f2c6674722e18
EBUILD hcloud-python-1.6.1.ebuild 927 BLAKE2B 951c1adde98b5ab1e6528427b686052e624315d9796ec0893ee37bece4e252a622c6c1e89e138e7f09674d6eb2a6499ca6bcac4009c749a5adeed132fa762bb2 SHA512 d9c6f88f6e5595a8a906b98246fb8b77a6097b06bb80a87aa852b1b9b27182a2bf4d90c8c11e863248e0a0c333ac1375e009fa83a7fb21c0374fc3fecf72717b
+EBUILD hcloud-python-1.6.2.ebuild 1039 BLAKE2B 3e2505436ef1b63099bd6e0cd2a31a15e80974a354e0f68aefa1aa80d1613779c9ac4de0c2d7f2faca739c3948cf1111cf306aa44b0e03bacb106865b244645a SHA512 18a740c72ce243b7f203c05190de1255f2be00d41c92a4696ac0e10f4171b47590d3f7cbfea7c18ca7a77aabf160565639b48c6ee19d55309ad30a2536ab23c3
MISC metadata.xml 246 BLAKE2B 5439993f129fd56fc43062bce991abdd20627118aa0e723a343c721cbc910de4f8b7b34b6f1587acfe0a60d488d4b1d093c69eb7d78f6accade89bced7d69b93 SHA512 482630597bd2d56c1eaed7099225b4475aec8768e20bad70ea9d6b96791fa38359ba572ab9ad0fc7ea72f1ab736ed1e92fc3c156c3427b008c7220285edce11c
diff --git a/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild b/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild
new file mode 100644
index 000000000000..d6166ae001a5
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND=">=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-2.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+ <dev-python/requests-2.23[${PYTHON_USEDEP}]"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
+ <dev-python/future-0.19[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}