summaryrefslogtreecommitdiff
path: root/dev-python/hatchling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
commit67e5603b2844a6657dd0438fa26626b013e5567f (patch)
treee7319631fdf1c41ddbe888e89a717d1ba42af992 /dev-python/hatchling
parentbff543bb632933380da922cbfc07c67157d72d42 (diff)
gentoo auto-resync : 24:06:2024 - 00:11:52
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest2
-rw-r--r--dev-python/hatchling/hatchling-1.25.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 6bc762a99933..6246558de123 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -1,3 +1,5 @@
DIST hatch-hatchling-v1.24.2.gh.tar.gz 1054297 BLAKE2B b2da7dc3f3d58998b57d6ee625a2b7e890afc078c0d8f6cb9c332480df561090bb8bc255e3e60d5d25fa55001869429f822014891fe1cec0098b61fbe02efe52 SHA512 e83f57089707a267685c9cac7f29cd5862adec62f6346097aa62bd5b3b9f7222621b2ea71004dd52f62798dab71bcf05c33a2c43dbe39d1bbc5f4a4f99f28c40
+DIST hatch-hatchling-v1.25.0.gh.tar.gz 5276942 BLAKE2B 76de1a824086889370a996945ad031179132dc74f4ef8a79da29913fc587c85210db49e89f400f4db2533d6706452cd4c67b87ff4ca97be0c3dc1879cf2bd77e SHA512 54f4e5f9383e846a9192e47b61f5147d4c48f20c41df752898dc5e22dd0bf196ea60fe4866dd04dc09c763aac67f7c047c40d978398e910878eb772af887d607
EBUILD hatchling-1.24.2.ebuild 2922 BLAKE2B 506fb6f862d54fc35adbe88fd542fba3ae6c5b023af893d5906b3db27dfe9369d529e0244dad394752acec23c166cb1c8c6a9e1bf0920aa31d263098f466bc81 SHA512 c0b7079e303e44c2865c599dab0157019c03f840649fa21db4b62f515140f0794e3ad8cd60529a151fe0401bc03d70b8869e42bda0542765d9c0120b39cf17b3
+EBUILD hatchling-1.25.0.ebuild 2930 BLAKE2B ee877ddafd84651691a8794c62c2d818d8c910d79cdaa605d4fb96796ddb6ee32aba82cfae0ca9e0b9cad02662ecd72a99d4936db265cd78f9550baf8e6d1594 SHA512 3553f1eb5ef859b270c6de76a55c79e26da10603e976e0c2d1b4bf3706994fea3a3de865260b376c5dcf387b9de0c623d21e1b3f77564e2e8a7f21408c48efa5
MISC metadata.xml 365 BLAKE2B 5a40a6cf6df042e6e8387830babd0171c9d8bc5d490fe2175b83d1588d827e826b49044ef29de48553515996b742fc475bb9699dcfa8ec05229162b22e0ed317 SHA512 f11bb25bc12c2bb0b0a0a4691115b9a2af525d9e44b33e0d6db98c7fcef0b49b5989fb7574ee8b27bc88f1dd2543bfdd492a6614de172e2c4edabbee8bf6161e
diff --git a/dev-python/hatchling/hatchling-1.25.0.ebuild b/dev-python/hatchling/hatchling-1.25.0.ebuild
new file mode 100644
index 000000000000..33191ee7e57c
--- /dev/null
+++ b/dev-python/hatchling/hatchling-1.25.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/pypa/hatch/
+"
+SRC_URI="
+ https://github.com/pypa/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# deps are listed in backend/src/hatchling/ouroboros.py
+# editables are optional but required for editable installs
+RDEPEND="
+ >=dev-python/editables-0.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.2[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# always depend on the newest version available, at least until upstream
+# stops treating unknown classifiers as a fatal error
+# https://github.com/pypa/hatch/issues/1368
+RDEPEND+="
+ >=dev-python/trove-classifiers-2024.3.25[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+
+ # sigh; standalone test suites are overrated, right?
+ echo "__version__ = '${PV}'" > src/hatch/_version.py || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+
+ # do not require uv for portability, sigh
+ mkdir "${T}/bin" || die
+ cat > "${T}/bin/uv" <<-EOF || die
+ #!/bin/sh
+ exit 127
+ EOF
+ chmod +x "${T}/bin/uv" || die
+ local -x PATH=${T}/bin:${PATH}
+
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x EPYTEST_DESELECT=(
+ # most of these run uv to install stuff
+ # the few remaining tests aren't worth running
+ tests/backend/dep/test_core.py
+ # broken if CARGO is set
+ tests/backend/builders/test_binary.py::TestBuildBootstrap::test_no_cargo
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock tests/backend
+}