summaryrefslogtreecommitdiff
path: root/dev-python/hatchling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
commit5043a584ce7a3eb644e68694a3266c1a5d2ccba5 (patch)
tree2401f70bb9284c4237ee848dcb65c610db18a643 /dev-python/hatchling
parentc1503bdaa031111d22d91db2f41dad440fb148e8 (diff)
gentoo auto-resync : 03:06:2023 - 21:32:31
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest2
-rw-r--r--dev-python/hatchling/hatchling-1.17.1.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index db7fb7a5633b..41a41086f349 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -1,3 +1,5 @@
DIST hatch-hatchling-v1.17.0.gh.tar.gz 383013 BLAKE2B 469d0d3e017d2dadcfdf9e2b4975f9e484739737a5c2d8fca9c55a4e519cf2e12b1ee44b3e26160476b3b990b15219a7075e692b58dcc4104b76b57395d8b0d1 SHA512 3649f2932c9963184deda5aac91726dad30ed88db2230377dc303714e0cdfd148b2fefc174ddeffff5cd95033bd984a35e3d297da02c29e4bfb7a6fb42f12dbd
+DIST hatch-hatchling-v1.17.1.gh.tar.gz 383218 BLAKE2B be31190492af5904aa9d8d10fa7f204d664599fc9543a6c3b5a3781bdc68a3f5f3fd2eabbd21e34e21ed8367c8253ed280b6aa5c6387268534799de4b75efa35 SHA512 2a9b163d10834b021f6ebd35484ebff01f22a7addbb2c472ec21dcc7a389e617d955935820bd7247d33fe79c4009e0e368a898b29fa0a3c7fff232f3bd7c424e
EBUILD hatchling-1.17.0.ebuild 2489 BLAKE2B c76ead3c546eaf1d822617ff5eb49e03b9a50337b43c791a7e6cd2c9c583e4d8913556933fe06c8311c1199f7ce8153fcef2b041a4d77dbd39139c6027a88f2a SHA512 9c56601089415491831489b087edab4dbc56410b9f1753d9859c1736f99c1990aa3de5c03c2499f9b986b5bac5737ff6a8a4d4a1e103e43bc1823f23dec05573
+EBUILD hatchling-1.17.1.ebuild 2497 BLAKE2B 36e510d58f217f9cf18d9010f72f17db4b9b86a1e9418f80ff05e9673fcf8ba9481fb941771f2c14d7cace67e19afc851f1815fc577e207bd6f80c8b31db72ee SHA512 ee2fb50b019c9a6e1f0a0a542069d44cc2d2e3d4c093f99023b8fd9ed9b1673add82203f462148db1740becb47b695221d5e3e186644186ca91c8374b2433e73
MISC metadata.xml 365 BLAKE2B 5a40a6cf6df042e6e8387830babd0171c9d8bc5d490fe2175b83d1588d827e826b49044ef29de48553515996b742fc475bb9699dcfa8ec05229162b22e0ed317 SHA512 f11bb25bc12c2bb0b0a0a4691115b9a2af525d9e44b33e0d6db98c7fcef0b49b5989fb7574ee8b27bc88f1dd2543bfdd492a6614de172e2c4edabbee8bf6161e
diff --git a/dev-python/hatchling/hatchling-1.17.1.ebuild b/dev-python/hatchling/hatchling-1.17.1.ebuild
new file mode 100644
index 000000000000..e4b0d169c421
--- /dev/null
+++ b/dev-python/hatchling/hatchling-1.17.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/pypa/hatch/
+"
+SRC_URI="
+ https://github.com/pypa/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# deps are listed in backend/src/hatchling/ouroboros.py
+RDEPEND="
+ >=dev-python/editables-0.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/trove-classifiers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x EPYTEST_DESELECT=(
+ # these run pip to install stuff
+ tests/backend/dep/test_core.py::test_dependency_found
+ tests/backend/dep/test_core.py::test_extra_met
+ tests/backend/dep/test_core.py::test_extra_no_dependencies
+ tests/backend/dep/test_core.py::test_extra_unmet
+ tests/backend/dep/test_core.py::test_unknown_extra
+ tests/backend/dep/test_core.py::test_version_unmet
+ # broken if CARGO is set
+ tests/backend/builders/test_app.py::TestBuildBootstrap::test_no_cargo
+ )
+
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+ # tests mock cargo subprocess call but the backend raises if CARGO
+ # is not set and shutil.which() can't find it
+ local -x CARGO=cargo
+ epytest tests/backend
+}