summaryrefslogtreecommitdiff
path: root/dev-python/hatch-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/hatch-vcs
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest3
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.2.0.ebuild29
-rw-r--r--dev-python/hatch-vcs/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
new file mode 100644
index 000000000000..376633782a82
--- /dev/null
+++ b/dev-python/hatch-vcs/Manifest
@@ -0,0 +1,3 @@
+DIST hatch-vcs-0.2.0.gh.tar.gz 8192 BLAKE2B 69f24de91b947e695336ca30cf3f265edcfaf10fa49df93fa0f70e45d1179e70d1ef5584fc99f88f66ca3c4fd1866a681db81253280ce3f9221d19f04443a085 SHA512 1c3627240ef5b659b9d87a69c84dd71cac4c83758f5be676e808377400383e996209cf6eabb1222f5330c0a97f0d261ced1eb9dc40e1d5c2bb2fc708659360eb
+EBUILD hatch-vcs-0.2.0.ebuild 656 BLAKE2B c2f666141552eeb3e67624c088ae7d487182909a91c0a764d716c4bfefe71a95fdb9cd07a0c6e4bca93752b0f590e2725b3d2c4d5711140b090a482c68b69049 SHA512 f133ad58296a729126261ac5959fe630c490e42c9862d99726cd6133e89ceb3298c8a35c654e7aea9479e7ef43d31b60b4f24ba67fe718d08bbbded34b0db2a4
+MISC metadata.xml 345 BLAKE2B 9483d276fbf90793ada8e95e4131830e756ebd65b29ef730aedabb12b46a33a3237c4f9ba99ca660006506f9bdb3a0a6c1642786ac763d2b85df029e3d0df56e SHA512 79d44066c15d5159331473aa2770cca340e05ac6565ba567229ad77f59c5421aad2146c44517c45210dd739bfdab8fab227cc5ab40979c04abb3c65c846d5f63
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.2.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.2.0.ebuild
new file mode 100644
index 000000000000..ff9ca3660636
--- /dev/null
+++ b/dev-python/hatch-vcs/hatch-vcs-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hatch plugin for versioning with your preferred VCS"
+HOMEPAGE="
+ https://pypi.org/project/hatch-vcs/
+ https://github.com/ofek/hatch-vcs/
+"
+SRC_URI="
+ https://github.com/ofek/hatch-vcs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/setuptools_scm-6.4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/hatch-vcs/metadata.xml b/dev-python/hatch-vcs/metadata.xml
new file mode 100644
index 000000000000..a9c9fbb19963
--- /dev/null
+++ b/dev-python/hatch-vcs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ofek/hatch-vcs</remote-id>
+ <remote-id type="pypi">hatch-vcs</remote-id>
+ </upstream>
+</pkgmetadata>