summaryrefslogtreecommitdiff
path: root/dev-python/hatch-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /dev-python/hatch-vcs
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest3
-rw-r--r--dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch32
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild6
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
index 18fce3865e32..f738c84db666 100644
--- a/dev-python/hatch-vcs/Manifest
+++ b/dev-python/hatch-vcs/Manifest
@@ -1,3 +1,4 @@
+AUX hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch 1217 BLAKE2B f0baf6b717b9cf5653b4b9bce4020d1b5d23cd03b382b1c00c75d78841434070cc8d5d27859b359e2ce32fb0d55b6c290e15702c981bb40fbc5f4a37e1b0b3b3 SHA512 b448e70a7058d88a8617fea38959e43257d28ac0c0e6753df229c974304f8c656349186d0cffd8e6693b3224717326f2fcf3e8476c6b70e8054e7c96e7745a1f
DIST hatch-vcs-0.3.0.gh.tar.gz 10049 BLAKE2B 69f49e205b4e42b46a246cc2403d8e7bbd2b8f83a360f1100ba98ecf7308d445e265749bd1f5fa7cca84104436e2643fd3f95292f2dba3dc48584a0df5136136 SHA512 ce22937aae8130a485ab154378f6c58c1720d66d277349a95ccfb58fd748deb69cd17d34ec3a12f3201f9e348e5d5b1c6b977432e614bb42d0e3065ec5f7f9c6
-EBUILD hatch-vcs-0.3.0.ebuild 691 BLAKE2B 38683a32d9be417c839a85f74419d0249a087472cfbc6142aa456a6ef2caae81b9f58e02470b6bbf0a889dfb57164a4a0fc5dfdb1c0acf96d3b29a0c93abfa62 SHA512 65471e9a7376fb7f97be5b3e94c7e416080c565ff48b1218c5f0b88a6f08a81d5938f36aaafb8877686c906b2cd8848c12ed480c5ffb25c6f844ce49d8a400f4
+EBUILD hatch-vcs-0.3.0.ebuild 776 BLAKE2B dddc8e6aa3c9fa4bbf129e4e67524fbe2c2d13e36ae556eb1a2689ea589c152bd69adef37e8faa8f2ecfecd2196c018c259495865689d326453fa0f1197a55ac SHA512 f2443631c39cc96fa7a645ed65e455a791d8618a6e11ca8e79ce05edcd871a73b4c216f92012687e9597c1c5ac3e195c2dee98f366682aea7dbc5448bef93991
MISC metadata.xml 369 BLAKE2B e834e5959ef7719c9ed9d751a8c5e56792fbd553e7fe0ae484a0f1da9c09e97fe262ccf319a773782207fd6a95b16662425f1b348090545b81a5391e70066ec3 SHA512 27b508fa717ff058f09f527c4ae504e131860229e073888b4b746621e1a877ef0c74f1336bdcc097969f9610f68d5e17ad1188efeb0ec4ff733097c4e86b027a
diff --git a/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch b/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
new file mode 100644
index 000000000000..919036acd720
--- /dev/null
+++ b/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
@@ -0,0 +1,32 @@
+From 47364faf5563df0eaa631ed10383817762c6b547 Mon Sep 17 00:00:00 2001
+From: Ben Beasley <code@musicinmybrain.net>
+Date: Thu, 5 Jan 2023 18:49:54 -0500
+Subject: [PATCH] Work with setuptools_scm 7.1 (fix #25) (#26)
+
+Make test_write less brittle (see also #8, #9) so that it works with
+_version.py files generated by at least setuptools_scm 7.1, 7.0, and
+6.x.
+---
+ tests/test_build.py | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_build.py b/tests/test_build.py
+index 2fde601..7c76343 100644
+--- a/tests/test_build.py
++++ b/tests/test_build.py
+@@ -75,8 +75,10 @@ def test_write(new_project_write):
+ assert os.path.isfile(version_file)
+
+ lines = read_file(version_file).splitlines()
+- assert lines[3].startswith(('version =', '__version__ ='))
+- assert lines[3].endswith("version = '1.2.3'")
++ version_starts = ('version = ', '__version__ = ')
++ assert any(line.startswith(version_starts) for line in lines)
++ version_line = next(line for line in lines if line.startswith(version_starts))
++ assert version_line.endswith(" = '1.2.3'")
+
+
+ @pytest.mark.skipif(sys.version_info[0] == 2, reason='Depends on fix in 6.4.0 which is Python 3-only')
+--
+2.39.1
+
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
index 56b375eb4b11..2f51c8ca8e20 100644
--- a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
+++ b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/setuptools_scm-6.4.0[${PYTHON_USEDEP}]
@@ -31,4 +31,8 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-Work-with-setuptools_scm-7.1-fix-25-26.patch
+)
+
distutils_enable_tests pytest