summaryrefslogtreecommitdiff
path: root/dev-python/hatch-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /dev-python/hatch-vcs
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest2
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
index 1cf521a9e184..1d517b95220c 100644
--- a/dev-python/hatch-vcs/Manifest
+++ b/dev-python/hatch-vcs/Manifest
@@ -1,4 +1,6 @@
AUX hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch 1217 BLAKE2B f0baf6b717b9cf5653b4b9bce4020d1b5d23cd03b382b1c00c75d78841434070cc8d5d27859b359e2ce32fb0d55b6c290e15702c981bb40fbc5f4a37e1b0b3b3 SHA512 b448e70a7058d88a8617fea38959e43257d28ac0c0e6753df229c974304f8c656349186d0cffd8e6693b3224717326f2fcf3e8476c6b70e8054e7c96e7745a1f
DIST hatch-vcs-0.3.0.gh.tar.gz 10049 BLAKE2B 69f49e205b4e42b46a246cc2403d8e7bbd2b8f83a360f1100ba98ecf7308d445e265749bd1f5fa7cca84104436e2643fd3f95292f2dba3dc48584a0df5136136 SHA512 ce22937aae8130a485ab154378f6c58c1720d66d277349a95ccfb58fd748deb69cd17d34ec3a12f3201f9e348e5d5b1c6b977432e614bb42d0e3065ec5f7f9c6
+DIST hatch-vcs-0.4.0.gh.tar.gz 10822 BLAKE2B 92b1ad1181a6bae815a6d01045836976b8767086f2a7001de9ad97f0d61737895da9a411419e28c5b2d830fca606d7d9c21265210965bc7691670f92aeab1b22 SHA512 bf40cc371c8d8e120fce83e5986fc2bdc2087fa5a4ac4a407d32617e98205ded79dcb29a00c7638ba68dd5ce09f31e84b34176627a6a34dfb7708031f4c4519a
EBUILD hatch-vcs-0.3.0.ebuild 801 BLAKE2B 23409ee07d904c59a2500ebf2549249afa8cc3af34cfc1df4462da92793450bed04b552e216b08262f249f337fb7361b86cdf3c92b2a7ab79e7f37c74a2a7b62 SHA512 2eab7c8937e39b4b1b267f5ff465bc0f0f9daebe5ecc59a03827719830bc952ff7cdf9fc97b4caf2e55b6d5b1e9ece7192ec8ae471d447628b0b699202be2422
+EBUILD hatch-vcs-0.4.0.ebuild 731 BLAKE2B 6f34f7d01bd428384410da7508b48ea76efd6567098b7983035d29b9c623b644bed25fa781fbcd415e13b53f161e03f678f5298087cd1379081efafe8a420177 SHA512 dcb539972e21b211e2919dae52576622bb22d254405d0504b8265b4fbb376d9be2f2adbb033d85280bf1532dce9b42ebc589d12cdba8ddebb01734819f4c08db
MISC metadata.xml 369 BLAKE2B e834e5959ef7719c9ed9d751a8c5e56792fbd553e7fe0ae484a0f1da9c09e97fe262ccf319a773782207fd6a95b16662425f1b348090545b81a5391e70066ec3 SHA512 27b508fa717ff058f09f527c4ae504e131860229e073888b4b746621e1a877ef0c74f1336bdcc097969f9610f68d5e17ad1188efeb0ec4ff733097c4e86b027a
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild
new file mode 100644
index 000000000000..2f7da06dc672
--- /dev/null
+++ b/dev-python/hatch-vcs/hatch-vcs-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hatch plugin for versioning with your preferred VCS"
+HOMEPAGE="
+ https://pypi.org/project/hatch-vcs/
+ https://github.com/ofek/hatch-vcs/
+"
+SRC_URI="
+ https://github.com/ofek/hatch-vcs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/setuptools-scm-6.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest