summaryrefslogtreecommitdiff
path: root/dev-python/hatch-jupyter-builder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
commitac616584d4bcb8e2a2defb591e3b0643054fda5d (patch)
tree2a1c72220398765d90183db696285fa3262ecdad /dev-python/hatch-jupyter-builder
parent1b76d39d04711631f8d9c7961d19e993e718e53c (diff)
gentoo auto-resync : 19:05:2023 - 16:15:42
Diffstat (limited to 'dev-python/hatch-jupyter-builder')
-rw-r--r--dev-python/hatch-jupyter-builder/Manifest3
-rw-r--r--dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild38
-rw-r--r--dev-python/hatch-jupyter-builder/metadata.xml13
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/hatch-jupyter-builder/Manifest b/dev-python/hatch-jupyter-builder/Manifest
new file mode 100644
index 000000000000..b800574126ce
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/Manifest
@@ -0,0 +1,3 @@
+DIST hatch_jupyter_builder-0.8.3.tar.gz 54754 BLAKE2B d64a90ba0e06dbbcfa3f2d27d88185f68bc6cadd885fd3691e01d129cb1d73d62efd2d230fe80dd2d8d1323b5efa4d3208f099663b2ed082a196a1b8fc39412e SHA512 c4dc0605338bafeeba21cc7260005815654d3e4646296d91af6fb3199be8645a06b2226608e6b0558ee01c7eed682162eefcf686a7e20636031b95c3a11ae265
+EBUILD hatch-jupyter-builder-0.8.3.ebuild 743 BLAKE2B bcd70f34c6ed4905e59881382122006abc55e62d32f29d46c37116313bfa32a5001d9e52a363ad95f2f8373ba8d328442d8a5fa5e027d79e4a0a8a1b640cebdb SHA512 256b56ada7bfca57f77018dc4fe64213b8a1efccef964c4062eb2ba381e4beac415c1ebd097f5341c22cf44fc4c0cc0d09d1957bd24ec79302f7f9e9273446d8
+MISC metadata.xml 434 BLAKE2B 4891ed3bf24cb6255d2edb5a9ea9203ea43c807cda50963e25cc6527caa20e1308271f1b5cbb246582491814db6e1743e083871ac044511eb5a5fd269288b623 SHA512 a9b103c28eac7767473c2499b9eeefb8796206b2d913bbd35ceb5ff30fbc16881b018d851381400bb0d544e9c9b710907ff52e17deb63a08440eec926c6633e0
diff --git a/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild b/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild
new file mode 100644
index 000000000000..2859ccbdd90e
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/hatch-jupyter-builder-0.8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A hatch plugin to help build Jupyter packages"
+HOMEPAGE="
+ https://pypi.org/project/hatch-jupyter-builder/
+ https://github.com/jupyterlab/hatch-jupyter-builder
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Calls pip, requires internet
+ tests/test_plugin.py::test_hatch_build
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/hatch-jupyter-builder/metadata.xml b/dev-python/hatch-jupyter-builder/metadata.xml
new file mode 100644
index 000000000000..af696c7da7fe
--- /dev/null
+++ b/dev-python/hatch-jupyter-builder/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">hatch-jupyter-builder</remote-id>
+ <remote-id type="github">jupyterlab/hatch-jupyter-builder</remote-id>
+ </upstream>
+</pkgmetadata>