summaryrefslogtreecommitdiff
path: root/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 20:35:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 20:35:08 +0100
commitf252a808abf092f718fbdfabb1c9b3ce51e62551 (patch)
treefd4d5d0c8c04a22190b7198efc5be56abf44a9f2 /dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild
parent3fb6e94893672e0dfbae682e6a3418e3f1260bf2 (diff)
gentoo auto-resync : 18:08:2022 - 20:35:07
Diffstat (limited to 'dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild')
-rw-r--r--dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild
new file mode 100644
index 000000000000..8d7f5fedb883
--- /dev/null
+++ b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Fancy PyPI READMEs with Hatch"
+HOMEPAGE="
+ https://pypi.org/project/hatch-fancy-pypi-readme/
+ https://github.com/hynek/hatch-fancy-pypi-readme
+"
+SRC_URI="
+ https://github.com/hynek/hatch-fancy-pypi-readme/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for self build a wheel? No need for that and fails.
+ tests/test_end_to_end.py
+)