summaryrefslogtreecommitdiff
path: root/dev-python/happybase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/happybase
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/happybase')
-rw-r--r--dev-python/happybase/Manifest3
-rw-r--r--dev-python/happybase/happybase-0.9_p20210701.ebuild33
-rw-r--r--dev-python/happybase/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/happybase/Manifest b/dev-python/happybase/Manifest
new file mode 100644
index 000000000000..2398ddb308f2
--- /dev/null
+++ b/dev-python/happybase/Manifest
@@ -0,0 +1,3 @@
+DIST happybase-0.9_p20210701.tar.gz 106551 BLAKE2B 66e39d8db10b8b7adbab5b77462560d50a2a494e1cd9b0411abd1c928cb4b630e42ca0cc6740c35cc9a3b65dab8e637df6ae6d4105665fa21fa7668324c82ec5 SHA512 b55028e6fe8b1087e835b01d373af6357ecc495e82badda6bd1641d1d7ef79d5ec72d3336ca7112b5b6886d28b4a6296336c96b83ce58740ea5802c4f11ab12e
+EBUILD happybase-0.9_p20210701.ebuild 841 BLAKE2B 83d7a461a15de5ed4767aa8a3590d57b9c9ec4a5ee9994c1eda73bda894be40c1c73459c1d35c3bdb3eef7e26b1af32f6e35d529cef15924ba0e6ceff74e506b SHA512 c0818a121b10f5451e159be568aae79c234b3d2bff9e9a84f10217ebe479b0a8853c8623cf3769c8c82fbbdb87f9159bd050330b0b14486001c18cda74d21237
+MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/dev-python/happybase/happybase-0.9_p20210701.ebuild b/dev-python/happybase/happybase-0.9_p20210701.ebuild
new file mode 100644
index 000000000000..0490d7a3842f
--- /dev/null
+++ b/dev-python/happybase/happybase-0.9_p20210701.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+COMMIT_HASH="f5b6d104140c2be93e4175c0c844aaf094eb43da"
+
+DESCRIPTION="A developer-friendly Python library to interact with Apache HBase"
+HOMEPAGE="https://github.com/python-happybase/happybase https://happybase.readthedocs.io/"
+SRC_URI="https://github.com/python-happybase/happybase/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/thriftpy2[${PYTHON_USEDEP}]
+"
+
+# tests require a running thrift server
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm pytest.ini || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/happybase/metadata.xml b/dev-python/happybase/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/dev-python/happybase/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>